13 Replies Latest reply: May 29, 2009 8:49 AM by volatileacid RSS

    Unable to start TFTP server on Windows Vista.

      Im having problems using the TFTP server on windows vista (Business 32bit). When i try to start the service, it times out and doesnt start. Either from services, or the TFTP gui, the result is the same.

      Ive had this problem when i evaluated engineers toolset, and now running the licensed version. Running windows XP everything works fine, but on Vista i have no luck.

       

      Any ideas? 

        • Re: Unable to start TFTP server on Windows Vista.
          mark wiggans

           Opening the TFTP Server does not automatically start the server service. To ensure the server is started, click File > Configure and review the Status section of the General tab.

            • Re: Unable to start TFTP server on Windows Vista.

              Thats sort of my problem, when i try to do what you say nothing happens. It times out and never start. Same thing happens when i try to start the service from service mmc snapin.

                • Re: Unable to start TFTP server on Windows Vista.
                  mark wiggans

                   If the DNS service is unable to resolve the signed .net runtime components of the following tools you may experience delayed start times, could this be the case? Are you using a mapped drive as a destination location?

                    • Re: Unable to start TFTP server on Windows Vista.

                      The computers are running without DNS.

                      I tried using a local drive, and a mapped network drive when starting TFTP server. The result is the same either way. 

                        • Re: Unable to start TFTP server on Windows Vista.
                          mark wiggans

                           hmmm, well verify the Windows Firewall is disabled to see if that helps and also check the advanced vista firewall configuration via "wf.msc" and open port 69 for TFTP service.

                          • Re: Unable to start TFTP server on Windows Vista.
                            davidmaltby

                            Do you mean that they are running without any DNS name resolution?  If so, then we wouldn't be able to verify the signed binaries.  Also, do you see anything in the TFTP logs that are located in


                             C:\Program Files\SolarWinds\Engineer's Toolset\Logging


                            that indicates that an error occured?


                             


                            Thanks,


                             


                              • Re: Unable to start TFTP server on Windows Vista.
                                Turning off the windows firewall makes no difference, and turning it off isnt an option, opening UDP port 69 is. But it has no effect either way.



                                As i replied in a previous post, the computers running solarwinds are without DNS name resolution, and my initial program startup delay applies to most solarwinds applications. Not just IPM.



                                The log to which you refer contains nothing interresting, but this log does (TFTPServer-gui.log.1)



                                08-02-05 14:18:00,745 [Main UI Thread] INFO TFTPServer.Instance - TFTP sevice: Start() function was invoked.
                                2008-02-05 14:18:30,791 [Main UI Thread] ERROR TFTPServer.Instance - "Cannot start SolarWinds Internal TFTP Server"
                                System.InvalidOperationException: Cannot start service SolarWinds TFTP Server on computer 'nett-stha'. - System.ComponentModel.Win32Exception: The service did not respond to the start or control request in a timely fashion
                                 --- End of inner exception stack trace ---
                                 at System.ServiceProcess.ServiceController.Start(String[] args)
                                 at System.ServiceProcess.ServiceController.Start()
                                 at TFTPServer.Instance.StartService(ServiceController TFTPserviceController)
                                2008-02-05 14:18:30,806 [Main UI Thread] INFO TFTPServer.Instance - TFTP sevice was started
                                
                                  • Re: Unable to start TFTP server on Windows Vista.

                                     Simple fix.. I had this issue as well and you will find this will resolve more Vista program issues to so keep it in the toolbox!

                                     Right-click on the SolarWinds TFTP Server Icon and select "Run As Admin"

                                     
                                    The program needs administrative privileges to start!

                                     

                                    ~MaCZeN~
                                     

                                      • Re: Unable to start TFTP server on Windows Vista.

                                        Or even:

                                         
                                        Start > Run > Services.msc

                                         
                                        and then search for 'Solarwinds TFTP server' , right-click the entry, and select Start.

                                         

                                         

                                         

                                         

                                        • Re: Unable to start TFTP server on Windows Vista.

                                           This worked for me with Vista, but I had to go to the actual program icon in the program folder- the shortcut would not work even as admin. and no firewall.

                                          Hope that helps anyone struggling with Vista and the TFTP server.

                                           

                                          JP

                                            • Re: Unable to start TFTP server on Windows Vista.

                                              Well, I know this is kind of old but I found it doing a search on Google.  I am a student taking a Cisco Academy course, and I just purchased for myself a used 2651xm router.  I am just trying to make a backup copy of the IOS image to my computer in case something happens.  I am running Windows Vista Ultimate and I have tried everything.  I ran it as administrator, went to services, and it still will not start the tftp server.  It is telling me that it can't find the file, and the service is pointing to the completely wrong location, not where it installed to at all.  The folder it is pointing to does exist, but it is empty.  I even tried making a shortcut file to the correct one and placing it in the folder, still will not go.  I can't change the location the service is pointing to, and it is getting really annoying.  Any help would be great.  I really wish Microsoft would fire and or shoot the "person" who invented UAC, it has been nothing but annoying and pointless.  I am the stinking administrator, let me do what I need to!  Argh...  Sorry, just needed to vent.

                                                • Re: Unable to start TFTP server on Windows Vista.

                                                  Again, I know this is an old post, but I did find a solution for it...
                                                  Delete the shortcut off the desktop.  Don't make any shortcuts, they don't work.  Why, ask MS...

                                                  Exit (not close) the existing TFTP server in the system tray.  It cannot be in memory or it will not work.

                                                  Go to c:\program files\solarwinds\tftpserver\ (or your install folder) and right click on tftpserver.exe and run as administrator.  Then do the "File => Configure => Start", then it runs fine.  This was verifed on a Windows 7 RC machine as well.

                                                    • Re: Unable to start TFTP server on Windows Vista.

                                                      Thanks for bringing this old post to our attention again. The problem has been resolved. The posts above detail the exact same solution you describe.

                                                      The problem ultimately is that the service isn't starting. Now whether one goes directly into services.msc and starts it manually, or runs tftpserver as an admin, and does this "File => Configure => Start", the end goal, i.e. getting the service to start is the same.

                                                       

                                                      I hope we can finally have closure on this! I need to unsubscribe from this thread.