3 Replies Latest reply on Jan 28, 2008 5:25 PM by Peter.Cooper

    Unknown Devices in scan engine

    bleearg13

      I currently have a bunch of devices in my scan results showing up as "Unknown" and the "Monitors to be added" column shows 'NaN'.  I'd like to get rid of all these monitors, but they don't seem to want to go away.  If I select them all and choose "Delete", it confirms that I want them deleted, but they don't go away.  I have a feeling this is why v9 just crashed while I was doing a scan.  Is there a way to clear out the scan engine results? 

        • Re: Unknown Devices in scan engine
          Peter.Cooper

          Is there a way to clear out the scan engine results? 
           

          Hello bleearg13. Yes, you can clear out the discovery stuff and start over. These instructions will obliterate all traces of data collected from two discovery engines (network discovery and device interrogation).

          1. net stop "solarwinds discovery engine"
          2. net stop "ipmonitorsrv"
          3. del c:\documents and settings\all users\application data\solarwinds\discoveryengine\ipmonitor9.dat
          4. del c:\program files\solarwinds\ipmonitor\config\networkscan.x
          5. net start "ipmonitorsrv"

          Before destroying these files, can you make copies of them? One of my colleagues, Matt, will get in touch with you to work with you regarding replication steps.

            • Re: Unknown Devices in scan engine
              bleearg13


              Before destroying these files, can you make copies of them? One of my colleagues, Matt, will get in touch with you to work with you regarding replication steps.


              No problem - I always make backups and sometimes backups of backups :-)  Just to be clear, this will only affect data that my network discovery engine has stored, correct?  If something goes wonky, I assume I can just restore the backup files?