4 Replies Latest reply on Jan 19, 2008 11:49 PM by fedorame

    what  is the matter with TFTP

      I've tried this so many times ,but always got :Could not download config from xxx.xxx.xxx.xxx.Transfer failed.Reason unknown.TFTP Server timeout?

      What does it mean?What should I do ?I missed something for the settings?

      Thanks in advance!

        • Re: what  is the matter with TFTP
          davidmaltby

          What version of TFTP Server are you using?  We had an issue with earlier versions.  Please try again using the latest version 9.2 of either Free TFTP Server or the Toolset.


           Thanks,


            • Re: what  is the matter with TFTP

              thank you davidmaltby ,but I am using the TFTP Server 9.2.0.47 that is a part of  SolarWinds Engineer's Toolset v9.2 .


              What is the problem?


              And I also encountered this :Transfer failed . Reason for failure can not be determined since router is using OLD-CISCO-MIB.


              BTW, I am in a LAN environment to manage the remote router.


              Thanks !

                • Re: what  is the matter with TFTP
                  davidmaltby

                  Can you describe your scenario in detail?  So, I assume the TFTP service is successfully started and doing a "netstat -an" shows that its listening on UDP port 69.


                  Is there a firewall in software (OS or 3rd party) on the box with the TFTP server?  From the LAN environment statement, I assume there is nothing on the network between the box and the router that would block traffic.  If there is a software firewall on the box, then make an exception for the "SolarWinds TFTP Server.exe" process, but make sure you don't accidently use the "TFTPServer.exe" process.  The later is just the UI, not the service.


                  Can you try to PUT a file from another box?... like in the following example (There are many free TFTP clients out there.  My example uses the client from http://www.tftp-server.com/tftp-client.html)


                  TFTP dmaltby-dev PUT c:\temp\putfile.txt \putfile.txt


                   If that fails, can you try to the same thing but run the client on the same box as the TFTP Server.  Then let me know your results. 


                  Also, there are log files for the TFTP Service under <Toolset Install Directory>\Logging\TFTPService.log


                  Thanks,


                    • Re: what  is the matter with TFTP

                      I can put a file from another box and on the same box with the TFTP client you provided.So I guess the TFTP is all right.I shuted down the firewalls (OS and Kaspersky),and tried again .But got the same words,even I was on net with ADSL. I suppose there is something wrong with the configuration of the router .


                      And I also sniffed the traffic when downloading .I got about 150 TFTP requests and responses .After that ,TFTP timeout.


                      Anyway,davidmaltby,I really appreciate your help !


                      Thanks.