6 Replies Latest reply on Feb 28, 2012 12:11 PM by DanielleH

    TFTP server .NET Runtime 2.0 Error

      I'm getting the following error in the Windows application event log when I attempt to run the TFTP server:

      Event Type:    Error

      Event Source:    .NET Runtime 2.0 Error Reporting
      Event Category:    None
      Event ID:    5000
      Date:        1/3/2008
      Time:        1:47:08 PM
      User:        N/A
      Computer:    OOBWIN1
      Description:
      EventType clr20r3, P1 tftpserver.exe, P2 9.1.0.111, P3 4729f97e, P4 system.drawing, P5 2.0.0.0, P6 461ef1b8, P7 14e, P8 d2, P9 amag3aacmawg2xaf344u21acve5pstkl, P10 NIL.

      When I double-click on the icon, it briefly shows an hourglass, then returns to the regular arrow pointer and nothing happens (except this event log entry).

      This only happens when I run TFTP server as a regular user.  It works correctly when run as an account with administrator privileges.  The machine is running Windows 2003 Server SP2.

      Does anyone have any advice for me?  I've used Solarwinds TFTP server in the past on my personal laptop and been very happy.

      Thanks,

      Andy 

        • Re: TFTP server .NET Runtime 2.0 Error
          mark wiggans

          Have you tried a repair on 2.0 framework install? You might also try adding that account as Admin for the TFTP service only>? Remember that you must be logged on to the Toolset computer with an administrator account to successfully run all of the tools

          • Re: TFTP server .NET Runtime 2.0 Error
            davidmaltby

            Can you look at the log files to see if there is anymore information?  Look in the install directory under Logging\TFTPService.log*


            Like Mark said, TFTP Server is intended to be run with administrative priviledge, but I'm will to help explorer the cause of your issue here.


             


            Thanks,


              • Re: TFTP server .NET Runtime 2.0 Error

                 I checked in the log files but all I saw were the successful attempts to run TFTP Server as an administrator.

                 I did some more testing on a separate box and I think I have found a difference.  On my testing box (Windows 2003 server with administrative terminal services), I am able to run TFTP Server as a normal user.  All I did was place my user account in the "Remote Desktop Users" group so that I could connect via RDP to the Windows server.

                However, the production server is running full-blown Windows Terminal Services.  Several of my coworkers have said that Windows Terminal Services applies additional restrictions (via group policy?) that are probably the cause of my problem.

                I'll keep digging for more information on this, but if anyone has other suggestions...

                 
                Thanks,

                   Andy