6 Replies Latest reply on Dec 5, 2007 6:19 PM by chris.lapoint

    SQL Monitor not working

    skierjmh

      I already have this monitored from our production Orion with the AM installed; APM doesn't see it as up. 

        • Re: SQL Monitor not working
          skierjmh

           And the APM
           

            • Re: SQL Monitor not working
              aLTeReGo

              The SQL Monitor uses WMI which requires Windows Authentication. You need to add account information to the credentials database that has WMI permission to that box.  Then you need to assign those credentials to the monitor..


              Hope that helps.

                • Re: SQL Monitor not working
                  chris.lapoint

                  AlTeReGo is exactly right.  The default SQL application template uses the WMI-based process monitors.  The advantage of the WMI-based process monitors is that you can monitor physical and virtual memory separately.   That said, the new APM module still has SNMP-based process monitors just like in the existing AM module.  You can try creating another  "SQL SNMP" application template and add the SNMP-based process monitors for SQL server processes.   That should do the trick.  

                    • Re: SQL Monitor not working
                      skierjmh
                      Yep that did work... the only problem is the SQL Port Monitor - doesn't work with SQL 2005.
                        • Re: SQL Monitor not working
                          aLTeReGo

                          I saw this too but I didn't report it because I couldn't find port 1433 open on my SQL 2005 Server. My SQL 2000 server does have this port open and the SQL monitor did function properly. I'm not a SQL expert so I'm not sure why port 1433 isn't open on my SQL 2005 server but I'm glad to see I'm not alone.

                            • Re: SQL Monitor not working
                              chris.lapoint

                              I noticed the exact same thing on my VM.  It appears that SQL 2005 turns off remote connections by default.  I found this article this MSDN article that describes how to fix this for SQL Server 2005:

                              http://support.microsoft.com/kb/914277

                              If you are using SQL 2006 Express like me, then it is more of a pain.  You must use the SQL Configuration Manager to enable Named Pipes and  enable TCP/IP for remote connections.  This is under SQL Server 2005 Network Configuration > Protocols.  You'll probably also want to start the SQL Browser service for good measure.   Then, I did a netstat -b to list ports by executable and looked for sqlsrvr.exe.   It turned out that it was not listening on 1433, but on 1406 (at least on my machine).

                              Hope this helps!