10 Replies Latest reply on Jan 15, 2008 7:17 PM by garykay357

    TFTP Server Issue

      OK I have TFTP Server installed on my Laptop.  When I installed the software my IP was 192.168.99.XX.  If I take my laptop to other networks within my Plant (192.168.105.XXX; 192.168.50.XXX) I cannot get the software to work.  It still wants to show the 192.168.99.XXX address. Is there someway to stop this?


       


      Thanks


      Harold

        • Re: TFTP Server Issue
          aLTeReGo

          What happens if you stop/start the TFTP service?

            • Re: TFTP Server Issue

              Nothing.  I have tried that, I have also tried reboot the PC a second time while connected to one of the other networks.

               Thanks for your help on this.
               

                • Re: TFTP Server Issue
                  aLTeReGo

                  It sounds like this is a cosmetic issue. Can you confirm this by running the following at a command prompt to verify the TFTP server is bound to the network adapter with the IP address you wish to use?



                   netstat -an | find ":69"


                  Should return something like



                  UDP    10.1.2.3:69           *:*


                  The IP address listed should be your current IP, and the IP address you wish to use the TFTP server with.

                    • Re: TFTP Server Issue
                      lchang

                      Hi,


                      I am having the same issue. I did the above netstat and it did not show up with my ip:69. What can I do to change it to use the nic I want it to?


                      Thanks...

                        • Re: TFTP Server Issue
                          aLTeReGo

                          Is the Solarwinds TFTP service started?


                          Do you have multiple adapters in your computer and are trying to bind the TFTP server to the non-default adapter?


                          Does the [netstat -an | find ":69"] return any results?


                           


                            • Re: TFTP Server Issue
                              lchang

                              I tried it with the TFTP service started and stopped.


                              I have a wireless adapter and the wired adapter. I don't remember trying to bind it to the wireless adapter.


                              The results:


                              C:\>netstat -an | find ":69"
                                UDP    0.0.0.0:69             *:*

                                • Re: TFTP Server Issue
                                  aLTeReGo

                                   

                                  C:\>netstat -an | find ":69"
                                    UDP    0.0.0.0:69             *:*



                                  0.0.0.0:69 means that there's a TFTP server bound to all adapters in the computer.


                                  Are you having trouble connecting to the TFTP server? Have you disabled the Windows firewall? Or any other firewalls for that matter?

                                    • Re: TFTP Server Issue
                                      lchang

                                      Hi,


                                      I wasn't able to disable the Windows firewall cuz my machine is under group policy, but I figured I saw the TFTP server was listed in the exceptions. Well, I tested on a laptop not in group policy and was able to turn off the Windows firewall and it worked. Turns out the exception wasn't allowing the correct .exe file through. Here's what fixed mine was allowing the following through:


                                      C:\Program Files\SolarWinds\TFTPServer\SolarWinds TFTP Server.exe


                                      The exception that wasn't working was C:\Program Files\SolarWinds\TFTPServer\TFTP Server.exe.


                                      Thanks for all the suggestions...

                                        • Re: TFTP Server Issue

                                          Hum... is Windows Vista your operating system?


                                           In Vista TFTP Server must be run as an administrator or it won't have permission to start TFTP service... Could that be your issue?


                                          About the firewall problem: I have it as well. If you find how to configure windows firewall for it to work with SW TFTP server please let me (us) know.


                                           Greets,


                                          Miguel

                                            • Re: TFTP Server Issue

                                              I'm using Vista Business edition with the Firewall enabled and found a work around. Go into the Windows Firewall settings, click on "Change Settings", click on the "Exceptions" tab, click on "Add port...", type in whatever you want under the name ie SW TFTP Server, enter 69 under the port number: and select the UDP radio button, click on OK, make sure that the port description you just created has it's check box selected (enabled), and click on OK. Start your SW TFTP Server and check on the status to make sure the TFTP server service is started. Once that's completed, you can use SW Config tool or telnet into your device and copy the config to your tftp server.


                                              Good luck


                                              Gary