5 Replies Latest reply on Sep 3, 2008 10:25 AM by greg@solarwinds.net

    switch port mapper problem w/ Dell

    rangertdc
      A sister company of ours just purchased the engineers toolset and we are also looking at buying it as well.  One of the tools we are excited about is switch port mapper.

      We are however having issues mapping ports on almost all of our Dell 5324 switches.  It seems like its polling all the information, but its only showing a single mac address on the uplink port.  Its showing port status, speed and type correctly for all ports however.

      I do notice when I run it against a 5324 that only has a single vlan it seems to work fine.  I tried the suggestion in other posts of using community@vlan but that didn't work.
        • Re: switch port mapper problem w/ Dell
          rangertdc

           Giving this post a bump.  We actually finally just purchased Engineers toolset version 9 and I'm still seeing the same problem with all of my dell switches.  I have to say, I'm kind of bummed.

            • Re: switch port mapper problem w/ Dell

              I suggest that you contact our technical support department so we can investigate this problem.  It would be helpful if you can give them a packet capture between the Switch Port Mapper and one of your Dell switches that has multiple VLANs.

              • Re: switch port mapper problem w/ Dell
                Eric E
                I'm not sure if you have Orion but I'm working on a resource that'll map MAC to IP addresses. It's currently working (tested) with Dell PowerConnect 3324's, 3348's , 3424's , 3448's, 6024's and 6024F's switches..
                  • Re: switch port mapper problem w/ Dell
                    rangertdc

                    Are you using single or multiple vlan configurations with your Dells?  It also works fine for me if I only use one vlan...but none of my switches use this basic of a configuration.  I've worked with support on this, given them packet traces, etc and have gotten nowhere.  I've since re-written parts of Cacti's Mactrack addon to work properly with my Dells...Not as handy as SPM would be if it worked...but it gets the job done.

                    Here was the last exchange I had with support:

                    From: Tim
                    To: SolarWinds.net, Inc.
                    Date: Dec 14 2007 - 9:36am

                    If you guys are unable to add support for the newer bridge mib, I just won't use switchport mapper.  From what Dell said, the dot1q bridge mib has replaced the dot1d bridge mib and they have no intention of continuing to support it for multiple vlans.
                     
                    I found another product that does support the qbridge mib properly and works great with all my dell and cisco devices, even the ones with multiple vlans, with no odd work-arounds.

                      _____ 

                    From: SolarWinds.net, Inc. [mailto:support@solarwinds.net]
                    Sent: Friday, December 14, 2007 4:50 AM
                    To: Tim
                    Subject: Case Update: 25427 - Switchport mapper not reading arp

                    Update for Case #25427 - "Switchport mapper not reading arp"

                    Hi Tim,

                    I will have to close this case, as the Dell device does not support the standard Bridge MIB.
                    I would suggest contacting Dell support, to find out if they have a method of enabling the dot1dTpFdbTable MIB table, or a workaround like the @vlan workaround that you could use.

                    Another suggestion would be to use the MIB Viewer in the Toolset. It will download the entire MIB table of whatever MIB you point it at - you can use it to retrieve the Bridge table used by the Dell Device, and then the ARP table of the router. It will be more awkward, but will still enable you to find out which device is connected to a certain port.

                    If you need this case re-opened, simply reply to this mail and I will reopen it for you.

                    Cheers,
                    Caroline