5 Replies Latest reply on Apr 23, 2019 6:27 PM by oscar89

    Action rule for Request Type = wrong assignment

    justin.gray@weldre4.k12.co.us

      I have an action rule to change the request type for certain email reports.  Once the request type is changed/updated the ticket does not get assigned to the proper tech for that group.

       

      So based on ticket history, here's what happens:

      1. Email arrives in WHD and is classified as 'Email Report'
      2. WHD assigns to 'Email Report' tech
      3. Action rule runs and changes Request Type from 'Email Report' to correct new Request Type (as intended).
      4. Tech assigned by 'Email Report' gets notification email.

       

      Once the action rule changes the request type, I would expect the ticket gets assigned to the proper tech based on the Request Type.  This is not happening.

       

      Further, with Action Rules, you cannot set a specific Tech Group, only a specific Tech, so I'm not sure how to get the assignment to happen based on Group.

       

      Any help out there?

        • Re: Action rule for Request Type = wrong assignment
          justin.gray@weldre4.k12.co.us

          Well, I was dead wrong there. While you can't achieve this via 'Modify Ticket' action, I found the additional action; Assign to > Tech Group

           

          So I added that action. And it doesn't work, either.

           

          Now I have in order:

          1. Email arrives
          2. Action rule runs and changes Request Type from 'Email Report' to correct new Request Type and now also sets it to the proper Tech Group
          3. Then WHD assigns it to the 'Email Report' tech and sends notification to the Email Report tech

           

          So now I have the correct Request Type and correct Tech Group set, but it still will not assign and notify the correct Tech based on those settings.

          justin.gray@weldre4.k12.co.us  wrote:

          Further, with Action Rules, you cannot set a specific Tech Group, only a specific Tech, so I'm not sure how to get the assignment to happen based on Group.

            • Re: Action rule for Request Type = wrong assignment
              oscar89

              if you go to:

               

              Setup >> Techs >> Tech Groups >> (Select the Tech Group that you need to auto-assign tickets) >> Tech Group Levels

               

              In the "Auto-Assign Tickets to" is there any option selected other than "None"?

               

              Also check the "Force E-Mail Notification To" and "Default Selected E-Mail Recipients" in the same section, verify that the level is also the right one and that Level Techs are assigned to that group.

                • Re: Action rule for Request Type = wrong assignment
                  justin.gray@weldre4.k12.co.us

                  Thanks for the reply.  Yes, currently we do the process manually and everything works as it should; change the Request Type and it gets assigned to the proper Tech based on the Tech Group. Proper Tech is notified, as well.

                   

                  The problem is specific to the Action Rule. If I had to guess, based on the timestamps all being the same, is that the actions are happening too close together and somewhat out of order.

                   

                  I can see that it comes in and is flagged as 'Email Report'. The rule runs and changes the request type to the correct type. After that, WHD then assigns to the Tech based on the initial 'Email Report' request type. At that point, however, it's no longer an Email Report.  Very puzzling.

              • Re: Action rule for Request Type = wrong assignment
                justin.gray@weldre4.k12.co.us

                Anyone experiencing this?  Essentially the Action Rule runs properly and sets the correct Request Type and Tech Group. But WHD does not assign it to the correct Tech once this happens.

                 

                Manually selecting either the Request Type or the Tech Group works properly, so I know this part is good.

                 

                So far support has been of no help. Their only suggestion has been to delete Tomcast temp files, increase the JVM memory and restart the services. This changed nothing.

                 

                I'd really appreciate any input!

                  • Re: Action rule for Request Type = wrong assignment
                    oscar89

                    I'm starting to think it is going to be a bug, or something not designed to work as you need it to.

                     

                    As a work around, I think you could try to create an action rule that Closes the "Email Report" ticket, and then it creates a new ticket with the new request type.

                     

                    So the downside is that you would have 2 tickets instead of 1, but you would have them linked by a parent-child relationship, and it would assign the correct Tech since it is a new ticket basically.