2 Replies Latest reply on Oct 11, 2018 10:01 AM by erichenriksson

    Directory and file listings

    erichenriksson

      Hi

       

      I've set up an account in Serv-U with a home directory on our network share.

      These are the folder rules:

      Folder settings

      The user was able to create subfolders and put files in them via FTP (21) access. I can see the folders and files on the NTFS share, but when they try to access the subfolders now from the FTP, the folders within are empty.

      If they try to create a new folder with the same name as an already existing one (which they can't see) they get an error saying the folder already exists.

      The NTFS permissions are set as inherited as well.

       

      The tree looks like this to them:

      Tree1

      But it should look more like this:

      Tree2

       

      We have tried many different clients (FTP Voyager, FileZilla, WebClient) with the same result.

      What could be a cause for this?

        • Re: Directory and file listings
          fluffy midnight

          HI erichenriksson,

           

          Your access path is fine, and as you can access the location appropriately we can presume this is working as expected.

           

          The error notifying you that a folder with that name already exists is true, it's just inaccessible as you cannot see or locate the folder.

           

          The usual cause for this kind of behaviour is insufficient privileges to the drive, I would suggest reviewing how this is set up.

           

          -Midnight

          2 of 2 people found this helpful
            • Re: Directory and file listings
              erichenriksson

              Hello, Fluffy

              It seems you were right, but I still can't really explain how.

               

              I tried setting up a new share and map that to the user, with very basic rights and it was working fine.

              After that I redid the share permissions and NTFS permissions for the original share. One thing I also did was to remove the hidden atttribute on the share ($).

               

              One or all of these things might have done the trick, but I still can't explain how I was able to access one level of subfolders/files but not the subsequent ones.

              Thank you for the help!