4 Replies Latest reply on Nov 2, 2004 10:16 AM by alonzo-garza

    Switch Port Mapper not finding addr & names

      Have a LAN in which an L3 switch is handling interVLAN routing between VLANs on 4 other switches. When I run SPM against any of the 4 switches, it misses most of the attached MAC addresses and all of the IP addresses and DNS/NetBIOS names. (The only MAC address it displays is that of the L3 switch port to which the switch being mapped is attached).
      I've tried using as router address the default gateway IP for the VLAN that the management machine is in, as well as the management VLAN address of the L3 switch.

      The network has been unchanged/stable for at least 3 months. I've verified that the L3 switch's ARP cache (MIB-II.atTable) does contain the IP addresses for all VLANs (and our access router connected to it does not contain these same IP addresses).

      In case it matters, the L3 switch is a Cisco 3550/IOS 12.1(11)EA1 and the 4 attached switches are 2924-XL/IOS 12.0(5)WC8. The interswitch link types don't appear to be significant here, but are a mix of 802.1Q and single VLAN links.
        • Re: Switch Port Mapper not finding addr & names
          Network_Guru
          There have been many posts regarding this issue.
          Please do a forum search on "port mapper" & you will find topics such as these:

          http://www2.solarwinds.net/SolarWinds-Forum/topic.asp?TOPIC_ID=93&SearchTerms=port+mapper

          http://www2.solarwinds.net/SolarWinds-Forum/topic.asp?TOPIC_ID=102&SearchTerms=port+mapper

          That's the beauty of a forum, your question has most likely been asked before, so you don't neccessarily have to wait for an answer.

          -=Cheers=-
                    NG
          • Re: Switch Port Mapper not finding addr & names
            Thanks for the pointers.

            If I understand correctly, this means to map a switch containing multiple VLANs we need to run SPM for each VLAN separately.

            It'd be useful if SPM also accepted a range or list of VLAN IDs, as in:  <community-string>{<VLAN ID>|<VLANx-VLANy>|<VLANx,VLANy,VLANz>}
            • Re: Switch Port Mapper not finding addr & names
              Let's try that again:
              <community-string>@{<VLAN ID>|<VLANx-VLANy>|<VLANx,VLANy,VLANz>}
              • Re: Switch Port Mapper not finding addr & names
                Hey bud,  There is a way for SPM to see all VLANs.  You need to go to "updates" section of your Solarwinds software and upgrade to the new Switch Port Mapper files that support VLAN's!  In that .zip file you will find an important file called SNMPv61.ocx




                Switch Port Mapper – Early Release Testing

                This is an early release of the Solarwinds Switch Port Mapper Version 6.0. This version will only work with a licensed Version 5.X Engineer Edition.

                To install this program, backup or rename your old version of SwitchPortMapper.exe.
                Unzip the PortMap.rtf and SwitchPortMapper.exe files into the \Program Files\Solarwinds\2002 Engineers Edition\ directory.   

                A new version of the SNMPv61.ocx is required and included.   SNMPv61.ocx needs to be copied into the \winnt\System32\ directory.  You can then register the control using the Regsvr32.exe command.

                1)     Copy the SNMPv61.ocx control to c:\windows\system32
                2)     Run the command    regsvr32 c:\windows\system32\snmpv61.ocx

                You should see a dialog box for RegSvr32 saying the DLLRegisterServer in snmpv61.ocx succeeded.

                What ‘s New in this Version
                1)     Cisco VLANS are now retrieved and the base community string is appended with each of the VLAN IDs automatically.   This solves the problem where you had to enter the community as public@(VLANNumber).  You no longer need to append the @number any more.  However, if you intentionally put a community string that includes an @ the VLAN table will not be retrieved, and only the single VLAN will be retrieved.
                2)     More interface properties are retrieved and can be selected for display.  Not all fields work on every vendor or every model by that vendor.  We just thought it was better to include the extras.
                3)     Support for SNMPv2 Get Bulk has been added to increase speed.  On devices that fail GetBulk testing during startup, Switch Port Mapper will fall back to SNMPv1 Gets.  SNMPv2 can be disabled under the Settings if needed.

                Rules about Reporting a Problem
                1)     Always give a clear description of the problem.  Problem details should include step by step instructions for recreating the problem.
                2)     Include the type of equipment you are trying to map.  Vendor, Model, Code Levels, and etc...
                3)     If possible, include a Packet Trace between the PC and the switch


                Holla, if you have any questions....Hope this works for you!

                -ALonzo

                "Fail to plan and you plan to fail" - Unknown Author