3 Replies Latest reply on Nov 5, 2004 2:39 PM by mjhamilton

    TFTP Server fails with Cisco AP

      Hello,

      I'm trying to update the firmware of a Cisco Access Point via TFTP.

      The AP starts downloanding the  new firmware but I see a timeout followed by a good transfer until the end then another attemp with timeout then another attempt now VERY SLOW then I get the following error:
      Run time error '52'
      Bad file name or number

      I thought the problem was the file name too long then I changed the file name to c1200v11.tar and still get errors.

      Please any inputs will be worth.

      thank you!
      gilmo
        • Re: TFTP Server fails with Cisco AP
          I experienced the same problem.  I solved it by loading some Windows updates.  I do not know exactly which update fixed the problem, but I am not receiving the error after applying the recommended.
          • Re: TFTP Server fails with Cisco AP
            Same goes with me, only my PC is already patched with the latest and greatest.  The problem is intermittent with no pattern to failure.  Also re-installed TFTP server and re-downloaded and re-installed.  Same thing.  Any other suggestions.  I'm trying to upload .bin files to Cisco switches
            • Re: TFTP Server fails with Cisco AP
              Cisco AP's are different to routers.... there is a folder created in the root of the flash folder and then sub folders under here.... there are the .bin files and .img files under the named folder and then the contents of the html folder is copied completely under here...

              All very confusing but the sub folders etc make it a real pain in the **** to upgrade IOS via TFTP as there are folders that must be created first and multiple files to copy across......

              The only foolproof way to upgrade a Cisco AP is via WLSE but this is not available to everyone..... not sure of another tool to make this one an easy task!!

              Martin J. Hamilton... lost in a sea of snmp...