0 Replies Latest reply on Aug 2, 2018 5:34 AM by wiltonp

    HTML POST fails in 12.3

    wiltonp

      I have had some fun with the latest release where it appears that the configuration wizard does not correctly set up the IIS directory on Server 2016.

       

      Initially I was on version 12.2 and I upgraded the server to 12.3.

      The first thing that I noticed was that when going to the website, it redirected me to /Orion/Logout.aspx and then errored saying too many re-directions. Changing the URL to /Orion/Login.aspx got around this iddue but all users experienced this same issue until the changed the URL once even if they tried clearing the cache or used a clean machine. From then on they did not get redirected to Logout so didn't encounter the issue again.

       

      However, we also use several custom resources that use HTML POST commands with PHP as the backend. These all fail to function as when you click on submit, it continues to the requested FORM page (normally itself) but does not provide any POST data. Please see my attached very simple test file.

       

      Note that using another website on the same server, same IIS instance etc works correctly but it is a different site from Solarwinds NetPerfMon.

       

      I have also tried with a vanilla build of the server with a clean install of Solarwinds NPM without it even on the domain with the same issue.

       

      I have also noted that in the Solarwinds site, opening Handler Mapping for any Handler named *-Integrated-4.0 (see attached). When opening *-4.0_32bit and *-4.0_64bit works without error.

      Other sites and the root/parent Handler Mapping has no errors and POST works correctly.

       

      Has anyone else seen this or has anyone any suggestions that may help in resolving my issue?

       

      I did raise a case with Solarwinds Technical Support but they have said that as this is with IIS and Customer Resources it is not something they will help any further with (although I was given a few idea which I tried without any success) even though I feel this is an issue with their Configuration Manager building the WebSite as this is something out of our control and appears to be where the issue lies.

       

      Thanks in advance