1 Reply Latest reply on Jun 6, 2018 4:02 AM by fluffy midnight

    Asset No. auto populating negative numbers


      I have configured and enabled WHD discovery connections which is working fine but for some reason it's generating negative asset numbers even if we add manual asset.

      Find attached screen snap.

        • Re: Asset No. auto populating negative numbers
          fluffy midnight

          Hi smalek,


          You have auto-incremental asset numbers enabled, this means that it takes the last value and adds a digit.


          At some point something has placed a minus value into the database, whether that be from a manual input or asset sync... To resolve the issue you could either go to the database and add a new row with an asset number you are happy to move on from, or try some trial and error with setting manual and automatic values to get it back on track (easiest option is going through the database, although if you aren't confident in doing this yourself you may want to get in touch with your dba or go ahead with the other option). Additionally you could just wipe your asset table and start again, so it starts from asset number 1... As a reminder for anyone making database changes, take backups and precautions before you make the change so you can restore if anything goes wrong.