3 Replies Latest reply on May 31, 2018 11:23 AM by mjewell

    Not all devices showing in SNMP report

    mjewell

      Hi all -

       

      New to NCM and I"m trying to work my way through some of the reporting here. Currently the stock report will give me almost all of my cisco equipment but for whatever reason my servers (physical and virtual) are not listed along with my storage devices. Any ideas what I can do to edit this and capture the device name, IP and SNMP community strings or WMI/ICMP data? I've been poking around for a bit and can't seem to piece that together.

       

      thanks all for any help!

      Mark

        • Re: Not all devices showing in SNMP report
          Mark Roberts

          Hi,

           

          The report you are referring to only displays devices for which SNMP data exists, which is why you will not get everything. You could create a report which shows the columns you require and ensure you do not put a filter in place.

           

          I have also shared a couple of reports from our library which together probably give you most of what you need. The default Agent Inventory report will cover servers being monitored via agent.

           

          Mark Roberts

          Prosperon - UK SolarWinds Partners

          Installation | Consultancy | Training | Licenses

          facebook_icon.jpglinkedin.pngblogger.pngtwitter-icon.jpg 

          2 of 2 people found this helpful
            • Re: Not all devices showing in SNMP report
              mjewell

              Hi Mark

               

              thanks for the reply and the reports. I had a feeling that was the issue (only pulling info for SNMP enabled endpoints) and was able to get around that by creating my own custom report using some of these variables.

               

              SELECT NodeID, ObjectSubType, IPAddress, IPAddressType, DynamicIP, Caption, StatCollection, External, Community, RWCommunity

               

               

              after playing with it for a long while I think I got what I needed but I'll go through what you shared as well.

               

              thanks!

              Mark

                • Re: Not all devices showing in SNMP report
                  mjewell

                  Hi all - figured it out and it was (as usual) easier than I thought.

                   

                  To export all the devices I have in SW I went to settings - manage nodes. Selected all from there and did an export with the data I wanted into a CSV that I could compare with the data I already had. That got me to where I wanted to be. Hope this helps someone.

                   

                  thanks!

                  Mark