5 Replies Latest reply on Apr 17, 2018 8:11 AM by havox

    Slack integration not working

    havox

      We are trying to implement alerting via a Slack channel and are running into problems.  After following the Solarwinds guide, everything works from the command line of the Orion server but we never get a message when it is triggered from an actual alert.  We see the "Send Slack Message" event task run in Orion but the message never shows up in Slack.  What could we be missing?  My guess is that it is a permissions issue when calling the curl.exe.  Is there a certain permission that should be allowed for this to work?

       

      Thanks,

      Jon

        • Re: Slack integration not working
          jm_sysadmin

          If the curl works when you run it, it may be permissions. Try to define a user to run the command:

            • Re: Slack integration not working
              havox

              Tried that and it didn't work.  We got this message Check 'Replace a process level token' account privilege of user which runs Solarwinds Orion Module Engine service.

               

              We did the following to the user account we are trying to use:

               

              - made local admin on Orion box

              - gave Full Control to curl script directory

              - made user the Log On account for the SolarWinds Orion Module Engine service

              - added user to "Replace a process level token" in Local Security Policy on Orion server

              - restarted all Orion services

               

              After adding the user to the Alert and running the Test Credentials, we get the same error as above.  I have used domain\username and username@domain with no success.  Solarwinds Support pretty much gave up and pointed me to Thwack.

               

              Thanks for the help.