0 Replies Latest reply on Apr 9, 2018 9:01 AM by bleearg13

    Cisco SF300 Series - Saving config and reboot issue in NCM

    bleearg13

      Hi,

      This is a real long shot, but is anyone else using NCM with Cisco SF-30x Small Business switches? My config backups work fine, but trying to save a configuration or reboot the device only randomly works - and sometimes it doesn't work, but the transfer results show that it succeeded. I believe the issue is the prompt that appears after running either the 'wr mem' or 'reload' commands. Again, backing up configs and making config changes is fine.

       

      Here is what is presented after doing a 'wr mem' or 'copy run start':

       

      Overwrite file [startup-config] ?[Yes/press any key for no]....

       

      Here is what is presented after entering 'reload' (two separate responses, based upon whether you've saved the config first or not):

       

      #reload
      You haven't saved your changes. Are you sure you want to continue ? (Y/N)[N] N
      This command will reset the whole system and disconnect your current session. Do you want to continue ? (Y/N)[N] 

       

      My device templates have the following as the 'SaveConfig' and 'Reboot' macros, respectively:

       

      <Command Name="Reboot" Value="reload${CRLF}y${CRLF}y"/>
      <Command Name="SaveConfig" Value="write memory${CRLF}Y"/>
      
      
      

       

      I've tried not using the macros and just entering the commands directly into the 'Execute Script' box when I run it, but it only very rarely works.

      Please tell me someone has some ideas here.