3 Replies Latest reply on Jun 8, 2018 2:35 AM by maryan.dmytriv

    vRealize Automation Integration

    mdsella

      We recently deployed VMware vRA/vRO and are beginning work on automating our server provisioning process.  With the recent update of Solarwinds IPAM, we have installed the vRO package according to the Solarwinds documentation.  So far, testing of the vRO workflows against our Solarwinds IPAM platform has worked well.  The next stage of implementation is to add the IPAM integration into vRA.  I see a vRO workflow for this, but so far it has not worked and I have not been able to find any documentation on this portion of the setup.  Based upon the Solarwinds webcast at the end of February, it looks like this integration should be possible.  Does anyone have any experience in integrating Solarwinds IPAM with vRA?

        • Re: vRealize Automation Integration
          ding

          Glad to hear that the vRO workflows are working well for you! For the vRA integration, take a look at this link: Customer Success: vRA integration

          This seems to be missing from the admin guide and I'll get this updated ASAP.

          • Re: vRealize Automation Integration
            eric.stacey

            I have also been trying to get this setup,  i finally got the IPAM Host added properly where i can run IPAM Operations via VRO.  but when i try to connect SloarWinds as an IPAM Endpoint to either the Default tenant or our custom tenant I get the below error.   I am trying to compare our settings to those in this guide (vRA integration - SolarWinds Worldwide, LLC. Help and Support )   but the images are so low rez i can't read anything and the steps are very under detailed. If anyone has this flushed out a bit more it would be super helpful.

             

            -----------ERROR ---------START-----------

             

            [2018-05-29 10:10:49.378] [E] 403  (Workflow:Register IPAM Endpoint / Register IPAM endpoint type in vRA (item5)#29)

            [2018-05-29 10:10:49.410] [E] Workflow execution stack:

            ***

            item: 'Register IPAM Endpoint/item4', state: 'failed', business state: 'null', exception: '403  (Workflow:Register IPAM Endpoint / Register IPAM endpoint type in vRA (item5)#29)'

            workflow: 'Register IPAM Endpoint' (450473b8-95dc-4c4f-be63-4b2ee050bb77)

            |  'attribute': name=errorCode type=string value=403  (Workflow:Register IPAM Endpoint / Register IPAM endpoint type in vRA (item5)#29)

            |  'attribute': name=vRASessionMode type=string value=Shared Session

            |  'attribute': name=vRAAcceptAllCertificates type=boolean value=true

            |  'attribute': name=vRAOperationTimeout type=number value=60.0

            |  'attribute': name=vRAConnectionTimeout type=number value=30.0

            |  'attribute': name=vRAConnectionPageSize type=number value=100.0

            |  'attribute': name=vRATenant type=string value=vsphere.local

            |  'attribute': name=vcacHost type=vCACCAFE:VCACHost value=dunes://service.dunes.ch/CustomSDKObject?id='2addb212-bf31-444d-98f8-cbb39872a8bc'&dunesName='vCACCAFE:VCACHost'

            |  'attribute': name=vRAName type=string value=

            |  'input': name=vRABaseUrl type=string value=

            |  'input': name=vRAUserName type=string value=administrator@vsphere.local

            |  'input': name=vRAPassword type=SecureString value=__NULL__

            |  'input': name=IPAMEndpoints type=Array/CompositeType(Name:string,Url:string,UserName:string,Password:SecureString,ExtensionData:Array/string):IPAMEndpoint value=null

            |  'input': name=useExistingVRAHost type=boolean value=true

            |  'input': name=vRAHOST type=vCACCAFE:VCACHost value=dunes://service.dunes.ch/CustomSDKObject?id='2addb212-bf31-444d-98f8-cbb39872a8bc'&dunesName='vCACCAFE:VCACHost'

            |  'no outputs'

            *** End of execution stack.

             

            -----------ERROR ---------END-----------