8 Replies Latest reply on Mar 13, 2018 11:04 AM by ebradford

    Error when trying to Browse MIB Tree in create new custom poller

    ebradford

      I am in Orion Universal Device Poller. I click New Universal Device Poller. When the new UDP app comes up, I click Browse MIB Tree. I get the error message, "object reference not set to an instance of an object." I searched Thwack and found several references of the issue, but it seems all were tied to specific node. In this case the error is happening without any specific node being selected. I ran database maintenance to see if that would help. It did not.

       

      Has anyone seen this before?: "object reference not set to an instance of an object" in UDP application when no node is selected?

        • Re: Error when trying to Browse MIB Tree in create new custom poller
          David Smith

          Hi ebradford what version of NPM & Core are you running on and when was the last time that it worked (if you can remember)?

           

          Are you able to run the configuration wizard to see if that fixes it (allow for a short outage window while it runs)

          • Re: Error when trying to Browse MIB Tree in create new custom poller
            cahunt

            Your ambiguous error; I believe, is just a pass through of a MS Error. Hence the reason for the ambiguity in the error message. Two things here though, are you setting a test node? And is the tree you are attempting to browse within the scope of the MIB for that test device?

             

            If you are not setting the test device, try setting the device that you want undp's for. This might help clean it up. Even if it does not and if your OID's are confirmed - create them anyways.

             

            Though honestly over the years I have had this error msg pop up when duplicating a UnDP, and creating a new one... some times just typing an OID in I get the msg on pop up half way through the OID(sometimes with each new .X entered [mainly older versions though, pre npm12.0]). Over the years I just click the msg so it goes away and I keep going.

             

            The error does come up usually when the application is trying to reference what you are doing with a specific object/entity and there is not that specific reference for what you are doing, within that specific object/entity. To me, The lack of reference/bad call creates a hiccup in the system and in this case SW does not provide an error, so the MS ambiguous error is passed through the SW App.

              • Re: Error when trying to Browse MIB Tree in create new custom poller
                ebradford

                Cahunt, Yes, I noted that in other posts on the same error message, they all seemed to be related to a specific object/entity. In my case, I had no object selected, and was still getting the error -- which told me that the other suggestions about deleted objects, etc., wouldn't apply. None the less, I ran DB maintenance, but that didn't fix it.

                 

                I tried several work arounds in the UDP app. I was initially trying to use 1.3.6.1.4.1.9.5.1.2.10 (CISCO-STACK-MIBchassisFanTestResult). When that didn't work, I tried 1.3.6.1.4.1.9 (Cisco); then I tried 1. Then I thought to put a dot in front of the 1, nope. So, I ignored the error, and used MIB Browser from Engineer's Toolset to explore around the OID. I created the UDP, and ran a test against several nodes. The test ran good all nodes. I went back now that I had valid test nodes, and tried to browse the MIB tree. Still, no dice. So, I am trying this with a known good OID on a known good test node, or even without any test node; it still gives the same error. 

                 

                There is the work around, but it's be nice to have UDP not return the error. Any thoughts?

                  • Re: Error when trying to Browse MIB Tree in create new custom poller
                    cahunt

                    In the past I have closed and re-opened the app. Sometimes that would help the error to 'go away'. Other times I just worked through the error - clicking on okay each pop up and getting to the end where that UnDP is in place to apply to a node (and this can be frustrating, as I've had that error pop up on almost each .X entry as I type in the OID [a lot of clicking but i still got there]). Second to that you might try a 'repair' on that app. It seems like the app is trying to reference something that is not there.... in which case I would say Dev would be able to break down what is happening and recommend an 'action or two'. But that would require a SW Support Case. If I think of or figure something else out, I'll post it here.

                • Re: Error when trying to Browse MIB Tree in create new custom poller
                  ebradford

                  Thanks for your help everyone. I have not found a solution yet, but the work around of using MIB Browser is okay.  If I find a reliable solution, I will post. We will be upgrading to a new version in a few weeks. I'll see if the error comes back afterward.