3 Replies Latest reply on Jan 31, 2018 9:29 AM by shalinz

    Importing csv file into IPAM

    shalinz

      I have been having this issue for a while now and it has been very frustrating.  We were on IPAM 4.3.2 until recently.  In 4.3.2, when trying to import a file, I would get the following error:

      Access Denied

      Your account has been found to have insufficient permissions to carry out the desired action.

       

      The account has full admin rights to not only IPAM, but every SolarWinds modules that we have installed.  I opened a support ticket for this and was told, that I have to upgrade to a newer version to get this working.  Well, we weren't able to upgrade due to other projects until recently.  I not only upgraded to 4.5.1, but we had actually uninstalled everything SolarWinds, and then installed NPM, IPAM, and SAM from scratch due to other issues we were having.

       

      After going to 4.5.1, I tried to import a file into IPAM and still get the same error.  I opened up another case with Support, and the answer again is to upgrade to resolve the issue.  I don't agree with that assessment and when I voice my concern about that, all I get is sorry you have to upgrade. 

       

      I also mentioned that we can't upgrade even if we wanted to as our environment still has Windows server 2008 R2 and SQL 2008.  We are planning a complete refresh of this environment to at least Windows Server 2012 and SQL 2012 so that we can install the newer version of modules but this won't happen until around the middle of this year.

       

      Again when I mention this, Support states that I have to upgrade and that they are closing the case since I have no other issues or questions!  Has anyone else run into this issue that might be able to help??

        • Re: Importing csv file into IPAM
          maryan.dmytriv

          Have you tried to give account Admin rights in IPAM group in edit account page? As a workaround you can create new Orion account with more priviliges like on the image

           

          • Re: Importing csv file into IPAM
            shalinz

            This has been resolved.  I called back into support and got transferred to a rep that assists with the Orion Core Platform. Call got sent to him since there was a long wait for IPAM support.  After spending an hour on the phone with him, we found out what the issue was.  A previous Orion Admin in my company had created a shortcut on the menu bar to import files into IPAM.  At some point (probably version 4.3.2) after an upgrade, the shortcut changed.

             

            When we went through the wizard to import a file it worked. So all we ended up having to do is update our shortcut on the menu bar.