1 Reply Latest reply on Nov 20, 2017 6:30 PM by serena

    NPM 12.2 Upgrade (IPAM ISSUES)

    chall2

      All,

       

      This is a long time coming, we have been trying to figure out multiple comparability issues when trying to perform NPM12.2 upgrade.

      We wanted to dry run the  upgrade in our LAB but at first we had no internet access in our lab to test out the online installers.

      Offline installers were the only option at that point. But the offline installers were still trying to reach the internet to download an installer package. Being there was no internet we had to work around this.

      We found we needed to upgrade some components that were not shown as having any comparability issues on the SolarWinds upgrade path guide.

      Actually after working with multiple Techs on the issue most of them said they do not use it any more with the falcon installer. You let it handle that part for you.

      Ok so fast forward to us getting thru the Falcon installer for NPM 12.2, it upgraded all of our components. But after configuration we would launch the website and it would prompt (IE prompt) for credentials.

      No matter what we put in it would just keep prompting over and over again. Eventually clicking cancel a bunch of times it loaded part of the website and we could tell it was broken. No top bar and no version information and a whole lot of RED.

       

      One of our support techs found it was an IPAM issue and recommended removing IPAM and the IPAM folders located in the Solarwinds  C:\ProgramData\Solarwinds.

      This removed our issue prompting us repetitively when trying to access the website. But We were unable to reinstall IPAM from either the Falcon installer or the MSI package.

       

      The tech asked for Diag and a repeat session possible with a Dev on the phone with us.

       

      Later:

      We actually got internet access in our lab and we were able to now test the online installer. But it did not make a difference we still ran into an issue with IPAM and the website.

      But we found the solution!!!

       

      SOLUTION:

      The Scheme files were corrupt.

      Location:  Program files(x86)\SolarWinds\Orion\Inforation Service\3.0\Schemas\

      Files: All IPAM files

       

      Remove those files either delete or just move them out of that directory. Then repair IPAM which will recreate the files. Then run the wizard.

      NOTE: we were unable to repair via add/remove programs we did it via the MSI: c:\ProgramData\Solarwinds\Installers\SolarWinds-Orion-IPAM.msi

       

      Current Install:

      2017.1.2 sp2, IPAM 4.3.2, SAM 6.3.0, DPAIM 11.0.0, NCM 7.5.1, VIM 7.1.0, QoE 2.3, Netpath 1.1.0, NPM12.1, NTA4.2.2, UDT 3.2.4, WPM(hasnt changed....)