2 Replies Latest reply on Oct 27, 2017 1:23 PM by rschroeder

    After upgrading NPM from 12.0.1 to 12.2, one e-mailed Alert works fine, but its view in the GUI of the node does not.  Why?

    rschroeder

      Here's an alert that works fine as an e-mail, and that USED TO work in the GUI of the Node with NPM 12.0.1, but does not work in the node's GUI in NPM 12.2.  Can you help me understand how to get it working again in the GUI?

       

      An issue has been detected at ${N=Alerting;M=AlertTriggerTime;F=DateTime} on ${N=SwisEntity;M=MachineType} device named ${N=SwisEntity;M=Caption} (IP: ${N=SwisEntity;M=IP_Address}, DNS: ${N=SwisEntity;M=DNS})

      View full device details here: ${N=SwisEntity;M=DetailsUrl}.

      View full alert details here: ${N=Alerting;M=AlertDetailsUrl}

      Click here to acknowledge the alert: ${N=Alerting;M=AcknowledgeUrl}

      This message was brought to you by the alert named: ${N=Alerting;M=AlertName}

      The node is monitored by the polling engine ${N=SwisEntity;M=Engine.ServerName}

       

       

       

      This is the successful e-mail, which shows when the device went down, and that provides links to its NPM page:

       

      With NPM 12.0.1, that Alert generated a pretty graphic in the Node's GUI that shows when it went down.  Now, instead of that nice graphic, we see this:

       

      A case opened with first-level SW Support wasn't helpful.  They said the above graphic is expected behavior, and that they don't have a 12.0.1 version to compare performance on.   Or in other words, take this Widget out of the NPM GUI for nodes and live without it.

       

      I'm hoping Thwack members can offer a way to get that data back into the GUI, maybe with a new / custom Alert?

       

      Any ideas / recommendations for achieving this?