0 Replies Latest reply on Jun 6, 2017 11:02 AM by tmcclintic

    Issues with Avaya Gateway Backup

    tmcclintic

      I have changed the terminal length to 200 (the max) but still get a prompt to press Enter at the end.

       

      [6/6/2017 10:51:24 AM] Save Command Output: !#

      [6/6/2017 10:51:24 AM] Process Line = <!# End of configuration file. Press Enter to continue.>

      [6/6/2017 10:51:24 AM] Fuzzy match detector start detecting prompt. String1=!#endofconfigurationfile.pressentertocontinue. String2=sod-1w-g450-1-006(super)#

      [6/6/2017 10:51:24 AM] <-- 

      [6/6/2017 10:51:24 AM] Non-Standard GotAMore detected. Send GotAMore from ProcessBuffer...

      [6/6/2017 10:51:24 AM] Process Line = <>

      [6/6/2017 10:51:24 AM] --->

      [6/6/2017 10:51:24 AM] Start check prompt for menu-based device

      [6/6/2017 10:51:24 AM] Process Line = < >

      [6/6/2017 10:51:24 AM] Config Prompt detector error: Invalid procedure call or argumentCurrentLine: 

      [6/6/2017 10:51:24 AM] Fuzzy match detector start detecting prompt. String1= String2=sod-1w-g450-1-006(super)#

      [6/6/2017 10:51:24 AM] Send GotAMore request to timer... LastData:   PushBackBuffer:

      [6/6/2017 10:51:24 AM] TimerTick: mstrData=< > State=3 - Connected to server - idle

      [6/6/2017 10:51:24 AM] Pending Disconnect = False

      [6/6/2017 10:51:25 AM] TimerTick: mstrData=< > State=3 - Connected to server - idle

      [6/6/2017 10:51:25 AM] Pending Disconnect = False

      [6/6/2017 10:51:25 AM] Timer Send GotAMore LastData:   PushBackBuffer: 

      [6/6/2017 10:51:25 AM] <-- 

      [6/6/2017 10:51:25 AM] Timer Send GotAMore: Clear LastData and last Goodline

      [6/6/2017 10:51:25 AM] Config Prompt detector error: Invalid procedure call or argumentCurrentLine:

      [6/6/2017 10:51:25 AM] Fuzzy match detector start detecting prompt. String1= String2=sod-1w-g450-1-006(super)#

      [6/6/2017 10:51:25 AM] TimerTick: Just tick-tockin away. ..

      [6/6/2017 10:51:25 AM] --->

      [6/6/2017 10:51:25 AM] Start check prompt for menu-based device

      [6/6/2017 10:51:25 AM] Process Line = < >

      [6/6/2017 10:51:25 AM] Config Prompt detector error: Invalid procedure call or argumentCurrentLine: 

      [6/6/2017 10:51:25 AM] Fuzzy match detector start detecting prompt. String1= String2=sod-1w-g450-1-006(super)#

      [6/6/2017 10:51:25 AM] Pushing back: < >

      [6/6/2017 10:51:25 AM] mPrompt is : <sod-1w-g450-1-006(super)# >

       

       

       

      I'm having issues getting NCM to get to the next stage and see the prompt. I have to use exact prompt as the config contains lines that have it. Here is my template.

       

      <Configuration-Management Device="" SystemOID="">

        <Commands>

          <Command Name="RESET" Value="terminal length 200${CRLF}terminal width 80" />

          <Command Name="Reboot" Value="reload${CRLF}y${CRLF}y" />

          <Command Name="EnterConfigMode" Value="config terminal" />

          <Command Name="ExitConfigMode" Value="end" />

          <Command Name="Startup" Value="startup" />

          <Command Name="Running" Value="running" />

          <Command Name="DownloadConfig" Value="show ${ConfigType}" />

          <Command Name="UploadConfig" Value="${EnterConfigMode}${CRLF}${ConfigText}${CRLF}${ExitConfigMode}" />

          <Command Name="DownloadConfigIndirect" Value="copy ${ConfigType} ${TransferProtocol}://${StorageAddress}/${StorageFilename}${CRLF}${CRLF}${CRLF}" />

          <Command Name="UploadConfigIndirect" Value="copy ${TransferProtocol}://${StorageAddress}/${StorageFilename}  ${ConfigType}${CRLF}${CRLF}" />

          <Command Name="DownloadConfigIndirectSCP" Value="copy ${ConfigType} ${TransferProtocol}://${SCPServerUserName}@${SCPStorageAddress}/${StorageFilename}${CRLF}${CRLF}${CRLF}${CRLF}${SCPServerPassword}" />

          <Command Name="UploadConfigIndirectSCP" Value="copy ${TransferProtocol}://${SCPServerUserName}@${SCPStorageAddress}/${StorageFilename}  ${ConfigType}${CRLF}${CRLF}${SCPServerPassword}" />

          <Command Name="EraseConfig" Value="write erase${CRLF}Y" />

          <Command Name="SaveConfig" Value="write memory" />

          <Command Name="Version" Value="show system" />

          <Command Name="Disconnect" Value="exit" />

          <Command Name="UseExactPromptMatch" Value="true" />

          <Command Name="More" Value="!# End of configuration file. Press Enter to continue." />

        </Commands>

      </Configuration-Management>

       

      You can see I have added the more value, but it is not working.

       

      Thank you have any help!