3 Replies Latest reply on Jun 7, 2017 2:56 AM by tomas.vrabel

    Orion SDK: Object reference not set to an instance of an object when executing Groups.ps1

    rrichter@vcpi.com

      Greetings Thwack!

       

      On the github page there is a sample script that serves as an example for adding groups to Orion: OrionSDK/Groups.ps1 at master · solarwinds/OrionSDK · GitHub

       

      When I try running that script as a test (with only editing the connection details) I get the following error:

      Invoke-SwisVerb : Object reference not set to an instance of an object.

      At D:\OrionScripts\Dependencies.ps1:35 char:13

      + $groupId = (Invoke-SwisVerb $swis "Orion.Container" "CreateContainer" @(

      + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      + CategoryInfo : InvalidOperation: (:) [Invoke-SwisVerb], FaultException`1

      + FullyQualifiedErrorId : SwisError,SwisPowerShell.InvokeSwisVerb

      Invoke-SwisVerb : Object reference not set to an instance of an object.

      At D:\OrionScripts\Dependencies.ps1:74 char:1

      + Invoke-SwisVerb $swis "Orion.Container" "AddDefinition" @(

      + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

      + CategoryInfo : InvalidOperation: (:) [Invoke-SwisVerb], FaultException`1

      + FullyQualifiedErrorId : SwisError,SwisPowerShell.InvokeSwisVerb

       

      Peculiar! Another thread on thwack Need help trying to add a node to a group container using Perl  recommended looking into the Information Services logs. I've attached the latest output from that log to this question. Sadly my own Orion-Fu isn't quite enough to decipher the XML to see what went wrong, or if I need go deeper.

       

      Currently running NPM 12.01. The script runs a-okay on a testing instance of Orion, but not in our prod environment.

       

      Message was edited by: Ryan Richter - Adding second InformationService.txt log