1 Reply Latest reply on Mar 29, 2017 9:23 AM by yupeng

    Failed to execute ctRunExternalScript by "Device.CLI.Send commands".

    yupeng

      1.Commands are as follows:

      “       

                sys

                %ctRunExternalScript("c:\cmdsent.vbs")

                di th

      "

      -------------------------------------------------------------------------------------------------

      2.the debug is

      "

      <NEWSESSION CatTools 3.11.0 2017/3/28 21:16:26>

      <PROTOCOL=Telnet>

      <DEVICE TYPE=Huawei.General>

      <ACTIVITY TYPE=Device.CLI.Send commands>

      <ACTIVITY SCRIPT=C:\Program Files (x86)\CatTools3\Scripts\Client.Device.CLI.Send commands.txt>

      <USERS NAME FOR DEVICE=10.189.251.107>

      <C OK 21:16:26>

      <R-21:16:26>[13][13][10][13][10]Login authentication[13][10][13][10][13][10]Username:

      <W-21:16:26>hw[13]

      <R-21:16:26>hw[13][10]Password:

      <W-21:16:26>abcd1111[13]

      <R-21:16:27>[13][10]Info: The max number of VTY users is 20, and the number[13][10]      of current VTY users on line is 1.[13][10]<CQZH3-PA-DCN-RT01-NE40E>

      <W-21:16:27>[13]

      <R-21:16:27>[13][10]<CQZH3-PA-DCN-RT01-NE40E>

      <W-21:16:27>sys

      <R-21:16:27>sys

      <W-21:16:27>[13]

      <R-21:16:27>[13][10]Enter system view, return user view with Ctrl+Z.[13][10][CQZH3-PA-DCN-RT01-NE40E]

      <W-21:16:27>%ctRunExternalScript("c:\cmdsent.vbs")

      <R-21:16:28>%ctRunExternalScript("c:\cmdsent.vbs")

      <W-21:16:28>[13]

      <R-21:16:28>[13][10]                         ^[13][10]Error: Unrecognized command found at '^' position.[13][10][CQZH3-PA-DCN-RT01-NE40E]

      <W-21:16:28>di th

      <R-21:16:28>di th

      "

      --------------------------------------------------------------------

      3.Question:

      Why   ”%ctRunExternalScript("c:\cmdsent.vbs")“  is not executed, but sent directly to the device。