0 Replies Latest reply on Feb 8, 2017 1:26 PM by vangesseld

    NPM Multicast Monitoring

    vangesseld

      Greetings Thwack Community,

       

      I'm trying to configure NPM to monitor multicast group changes in a more useful way. What I'm trying to accomplish is to trigger an alert on specific group ranges when they transition from a state of having traffic, to either a state of down or no traffic. I think my logic is a bit messed up in how I've got this set up, because when I tested with a multicast group it failed to trigger the alert. Also, this alert seems to always be triggered for all multicast groups that are traversing a Juniper MX virtual chassis (but doesn't trigger a false alarm on Juniper MX devices that aren't using virtual chassis).

       

      Here's the trigger conditions I have set:

       

      Scope of this Alert:

       

      At least one child condition must be satisfied (OR) 
          All child conditions must be satisfied (AND)
            Multicast Groups - Group IP - is greater than or equal to - 232.0.0.0
            Multicast Groups - Group IP - is less than or equal to - 232.255.255.255
            Multicast Group Nodes - Source packets per second - is greater than or equal to - 100
          All child conditions must be satisfied (AND)
            Multicast Groups - Group IP - is greater than or equal to - 239.0.0.0
            Multicast Groups - Group IP - is less than or equal to - 239.255.255.255
            Multicast Group Nodes - Source packets per second - is greater than or equal to - 100

         Trigger Condition:

       

      Multicast Group Nodes - Source packets per second - is equal to - 0

        Reset Condition:

       

      When the trigger condition is no longer true

       

       

      I'm fairly certain that this isn't working the way that I want because of flawed logic, but I've been playing with this for a while and I either get nothing, or I get false positives on a lot of groups that are no longer in use, or are in use and actually working properly.

       

      I tried searching on this topic, but the vast majority of discussions surrounding this are simply related to turning the feature off as opposed to trying to make it more useful.

       

      Can anyone offer any advice on how to get this working the way I described? Has anyone seen issues with this on Juniper MX virtual chassis environments?