6 Replies Latest reply on Jul 14, 2017 3:22 AM by HerrDoktor

    SolarWinds / ServiceNOW Integration Issue

    llemieux

      Hello,

       

      Recently we established an instance in SolarWinds with our ServiceNOW environment. Everything involving that process went well. The issue I'm experiencing is during the creation of the trigger action that generates the incident within ServiceNOW.

       

      For some reason the fields we have specified that match our incident forms in ServiceNOW show a 'null' value. As anyone seen this before? Screenshot attached. We believe it may be related to a permission issue with our ServiceNOW account created for the SolarWinds integration, but are just not sure.

        • Re: SolarWinds / ServiceNOW Integration Issue
          abhishek2609

          Hello,

           

          Once you create a user account on ServiceNow, make sure that you have:

          1. Created a user with 'Webservice' access only.

          2. And in the roles - the 'x_sow_intapp.integration_user' role is added to the role list.

           

          Also, make sure that you have successfully tested the service now instance after you have added the instance in to the Orion console.

            • Re: SolarWinds / ServiceNOW Integration Issue
              llemieux

              Yes, both have been applied to the created user in SeviceNow.

               

              Opened up a case with support, but have received no response yet.

               

              Tried deleting and recreating the instances in SolarWinds, along with giving the user account in ServiceNow ITIL permissions. Values are still being pulled as 'Null'.

                • Re: SolarWinds / ServiceNOW Integration Issue
                  llemieux

                  In case anyone else may happen to come across this in the interim, support still has no resolution on this issue for me. Set up of the ServiceNow intergrations are correct with proper permission applied, and debugging information has been sent to development twice.

                   

                  We have tried  creating a TcpTimedWaitDelay DWORD Value within: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters using a decimal value of 30 and still no resolution.

                   

                  Have also tried installation of the recommended buddy drop: Orion-v2016.1.0-BD-RM-1286 issue was still not resolved. Currently waiting to hear back from support.

              • Re: SolarWinds / ServiceNOW Integration Issue
                ajaypal

                Hi Nitin,

                 

                Integration between ServieNow and Solarwind can be achieved using SynQ

                 

                 

                You can also follow this blog for more information on integrating between Servicenow to Solarwind.

                 

                Thanks

                Ajay