2 Replies Latest reply on Feb 3, 2017 11:26 AM by btatum17

    Inventory Question: Workgroup systems with same computer name

    btatum17

      Does anyone know if the inventory database is limited in my following scenario. My deployment is used to manage both a domain and non-domain setting. The non-domain setting contain multiple sites with unique IP addressing but a repeat of the same machine names. When I run an inventory and then try to get reporting of these systems I get one entry for say "ComputerA" "ComputerB" etc.. when there should be many "ComputerA" with different IP addresses in each entry as there are many machines named "ComputerA". I have unique DNS Suffix names added on these workgroup computers and that is how WSUS is able to bring them in knowing they are unique names but not having much luck getting any reporting from Patch Manager on all my systems. They all show up in the main Patch Manger console under their respective WSUS server. If there is a way to have them report the full name with dns suffix that might be the key or could be the basis for a hotfix option. 

       

      Maybe someone knows if this is a limitation or if there is a work around or maybe I can talk to support and get a hotfix for my system that will help. I wanted to try here first before support.and get any input. Attached is the example report setting I am running. -thanks

        • Re: Inventory Question: Workgroup systems with same computer name
          frgpugs

          im not positive this would do what you want but have you tried to change the adapter properties for the nic on affected PCs under TCP/IP V4, advanced, DNS tab, check box for use this connections suffix in dns registrations?

            • Re: Inventory Question: Workgroup systems with same computer name
              btatum17

              thanks for the input. I didn't have that option checked and tried it on a couple machines. I rebooted and refreshed dns registration to the server. I haven't seen a change yet in the behavior. I run a report and see "ComputerA" with say IP address 192.168.254.10 and then when I do a forced inventory pull on another "ComputerA" with a different IP and run the report again the previous one is gone and the new one is there with a different IP address. I think there is a limitation in how the data is handled basing it off the computer name only and allowing only one of each name to be populated. I will keep exploring this to see what I can find. I would rename the systems if I could but it would break stuff and there are like 500+.