16 Replies Latest reply on Jan 24, 2017 1:57 PM by jjones13

    Download cofig issue

    kai

      Im new to Solarwinds Orion, never used it before. Manager wants me to solve this error :

       

      ERROR: Cannot download Running config : Cannot Log into Device : bad password. Device IP: xxxxxxx

       

      ..this is one of 83 devices with the same error. 2 days now and im not getting anywhere...so I signed up here

      One of server analyst suggested could be because of account privileges. I can access through telnet but just wont download any config. They used to work, but not anymore.

        • Re: Download cofig issue
          Chris T

          Try going into one of the nodes that is having issues and test the account you are trying to use. If you edit the properties of the node and scroll to the bottom where it has Manage Node with NCM check the connection profile that it is using for the device. There is also a test button there that you can use to make sure it is working right.

           

          2 of 2 people found this helpful
            • Re: Download cofig issue
              kai

              hi chris, I checked and it seems to have the same setting as the other devices that can download configs. I clicked test on NCM properties and same error showed up again. Any other ideas?

               

              Thanks again

                • Re: Download cofig issue
                  rschroeder

                  The key is to set up NCM to access the device remotely exactly as you would do it from your PC.  Some things to check:

                  • Ensure the NCM service account has appropriate rights to the device via TACACS or RADIUS if you're using them
                  • Confirm the password NCM uses is the same you successfully log into the device with--no spaces, no typos, etc.  Copying with Windows and pasting into NCM often inserts a space at the end, which is going to make the password invalid
                  • Verify NCM uses the same protocol as you do.  If you disable telnet and SSH v1, and force all traffic to use SSH v2, your NCM setup for that device must also be forced to use SSH v2
                  • If you use TACACS, review the logs to see more detail about the error.  You can trust NCM to give you the correct information; somewhere you've entered an incorrect password into NCM for this device, but TACACS might provide the depth of troubleshooting you need
                  • If the problem device happens to be a Cisco ASA, manually select it in the Device Template.  Otherwise, I've had perfect functionality letting NPM/NCM select the correct template automatically

                   

                  Post some screen shots for us to troubleshoot with you.  I'm sure you'll get it as long as the device uses the password you've set in NCM, and as long as the NCM service account has the correct privileges locally on the switch and remotely in TACACS.

                  2 of 2 people found this helpful
              • Re: Download cofig issue
                bud

                Have you tried to reenter the password for the node in the NCM properties?  I have had issues where SNMP v3 credentials stopped working and just updated them.

                 

                Is your netadmin account your global account for Solarwinds to use?  I ask this because your settings don't show the global variables.  Also, when you run the test, what does the "show credential login details" show?

                 

                Connection Profile                                                                          Manage Connection Profiles                                             
                                    Global Connection Profile:                                 
                                    Login Credentials:                                 
                                    Username:                                  Reset to ${GlobalUsername}                
                                    Password:                                  Reset to ${GlobalPassword}                
                                    Enable Level:                                                      
                                    Enable Password:                                  Reset to ${GlobalEnablePassword}                
                                    Execute Scripts Using:                                 
                                    Request Configs Using:                                 
                                    Transfer Configs Using:                                 
                                    Telnet Port:                                  Reset to ${GlobalTelnetPort}                
                                    SSH Port:                                  Reset to ${GlobalSSHPort}                
                                     

                 

                Test                 Show Macro Values                
                • Re: Download cofig issue
                  kai

                  Solarwinds support figured out the cause

                   

                   

                  instead of startup-config, its just config

                  thanks a lot guys for the effort

                  2 of 2 people found this helpful
                  • Re: Download cofig issue
                    jjones13

                    Have you logged onto the server and tried to do a telnet session from there? I'm not sure how your environment is setup but telnet may be allowed from your workstation but being blocked when coming from the Solarwinds server.