10 Replies Latest reply on Jan 10, 2017 5:41 PM by kellytice

    Why aren't my Java applicability rules working?

    twanorati

      Background: I have a lot of Java 6 in my environment and I'm trying to get rid of it. To do that, I've created a Package which should target all computers with old Java versions (including 6), and running the latest Java 8 installer with the REMOVEOUTOFDATEJRES=1 switch.

       

      My issue is that I'm seeing computers that I know should be applicable show up as Not Applicable. This update has been published for over a month now, so there should have been plenty of time for all computers to check-in and update their applicability.

       

      Here are my applicability rules for the package (x86):

       

      Capture.JPG

       

      The idea is to look for either Java 8 if it is less that the current version OR any previous major version of Java.

       

      Here is a shot of the registry from a computer that is showing as Not Applicable in Patch Manager:

       

      Capture2.JPG

       

      The reg key HKLM\SOFTWARE\JavaSoft\Java Runtime Environment\1.6 definitely exists on that computer, and that computer has reported in to WSUS as recently as today. What am I missing?