5 Replies Latest reply on Apr 13, 2017 11:05 AM by whitz3nd

    FTP Voyager - Does it support TLS 1.1

    joleneme

      We need to send a document via FTP over TLS (Explicit) using TLS 1.1.  Does FTP Voyager 16.1 support that?  If so, how do I get my site profile to use that?

       

      Thanks

        • Re: FTP Voyager - Does it support TLS 1.1
          thegreateebzies

          Hello Jolene! I've forwarded a link to this question to the support team of RhinoSoft. They should be reaching out shortly to answer your question.

          • Re: FTP Voyager - Does it support TLS 1.1
            mbussey

            Hi Jolene,

            This should help - http://www.serv-u.com/kb/1028/Setting-Up-a-Site-to-Use-SSL-in-FTP-Voyager

            You might want to try either;

            FTP over TLS (explicit)

            FTP over SSL (explicit) in the profile settings

            • Re: FTP Voyager - Does it support TLS 1.1
              whitz3nd

              Good afternoon,

              We have had FTP Voyager setup for quite a while to handle the shifting of files between us and clients with the automation/scheduler that is offered with FTP Voyager.  We updated our FTP server to only allow TLS 1.1+ moving forward to comply with security measures and policies set forth by the company.  Since doing so, FTP voyager does not negotiate with the server, on my server logs I see this repeatedly:

              [2017-04-11 14:30:34]:CONNECT [ 26019] - Incoming connection request on FTPS interface 9 at 0.0.0.0

              [2017-04-11 14:30:34]:CONNECT [ 26019] - FTPS connection request accepted from 0.0.0.0

              [2017-04-11 14:30:34]:  ERROR [ 26019] - SSL accept error: A failure in the SSL library occurred, usually a protocol error: unknown protocol

              [2017-04-11 14:30:34]:  ERROR [ 26019] - Unable to establish secure FTPS connection

              [2017-04-11 14:30:34]:CONNECT [ 26019] - Connection terminated

               

              This happens over and over again.  I test with Filezilla from the same server using all the same configurations and it connects right in without issue.

               

              Now, when I go back onto the FTP server and enable TLS 1.0 and try to connect again with FTP Voyager it then connects in without any issues at all.

               

              Is there any update on this on when there is a plan to release an patch/update for FTP Voyager to support TLS 1.1 and above?  We would really like to continue using FTP Voyager but if there is not a plan to support anything higher then we will need to start looking someplace else.

              Thank you