25 Replies Latest reply on Sep 13, 2016 11:09 PM by shuth

    SAM RC 6.3

    squinsey

      The email from aLTeReGo / Jeremy has only been out for a couple of hours (it's Saturday morning here in Australia).

      I'm actually kinda wishing it was Monday already, so I can get in to work early to make time and have a crack at getting this baby up and running.

      Then I'll even scrounge around for spare VM slices from somewhere to get a HA setup going. Oh Yeah!

       

      So, have you - our US counterparts stayed back after getting the announcement and ordered in Pizza and Beer for a Friday night upgrade party?

      How did you go? Anything of a concern? Has it cured some of those underlying issues you've had? 

        • Re: SAM RC 6.3
          shuth

          Downloaded the modules and going to install tomorrow. I might run up some more servers to try the additional poller install and HA clustering.

          • Re: SAM RC 6.3
            Steven Hunt

            If you were in Austin, I might have been enticed to fund the pizza and beer party.

            • Re: SAM RC 6.3
              designerfx

              Wishing I could actually test this, alas.

              • Re: SAM RC 6.3
                thedoclady

                SAM RC Documentation is live!

                 

                Check everything from Release Notes, quick info on new features, new Admin Guide, new online help (offline version for RC), updated template guide, and much more! I'll keep updating the RC drafts as any further developments come up, change, get addressed, and more.

                 

                Server & Application Monitor (SAM) 6.3 - SolarWinds Worldwide, LLC. Help and Support

                 

                With GA, the template guide will also be in the online help with all those component monitor template thwack links updated.

                 

                Thanks and enjoy!

                Lori the SW Doc Lady

                1 of 1 people found this helpful
                • Re: SAM RC 6.3
                  aLTeReGo

                  Reports have begun trickling in from others and aside from a few installation annoyances, functionality and stability has been rock solid. All installation issues have been easily overcome by forcibly shutting down all services which appear to be holding open files and locking them for some users. This includes stopping all Dependencies and the website itself if you encounter the error below.

                   

                  NPM_inst_error.png

                   

                  There is also some general confusion surrounding the new Install/upgrade process for Additional Polling Engines and Additional Web Servers. We have deprecated the individual APE and AWS product installers and replaced them with a tiny unified Scalability Engines Installer. This installer is now included in-product and can be download from the Orion web interface from [Settings -> All Settings -> Polling Engines] and [Settings -> All Settings -> Web Console Settings].  This single installer will upgrade all Orion modules on each of your Additional Pollers or Additional Web Servers. It has the distinct advantage of being orders of magnitude faster than installing each product module separately. Some customers have reported a greater than 400% reduction in the amount of time it now takes them to upgrade their Additional Polling Engines and Additional Web Servers, which translates into far less downtime incurred when doing upgrades. WOOT!

                   

                  All this awesome does however come with a small cost. All Orion modules installed on the main/primary must be running the latest version to support this new install/upgrade method. If when upgrading your Additional Polling Engine or Additional Web Server you receive the following error, it's stating (albeit poorly) that one of the Orion modules installed on your primary/main is out-of-date and must be upgraded to the latest version before you can upgrade the APE or AWS. The minimum supported versions table below can be used for reference.

                   

                  image001.pngMinimum Supported Product Version.png

                  3 of 3 people found this helpful
                    • Re: SAM RC 6.3
                      squinsey

                      Thanks aLTeReGo, making notes whilst my Dev instance is taken offline for the Db and VM backups. Allows me to rollback to align with Prod for the GA upgrade later.

                      Orion Platform 2016.1.5300, WPM 2.2.1, IPAM 4.3.2, SRM 6.3.0, VNQM 4.2.4, NCM 7.5, NPM 12.0, QoE 2.1.0, NTA 4.2.0, IVIM 2.1.2, SAM 6.2.4, NetPath 1.0

                      • Re: SAM RC 6.3
                        thedoclady

                        I'll get the info on the Scalability Engine Installer into the upgrade guide! Definitely awesome.

                        • Re: SAM RC 6.3
                          squinsey

                          Hrmm. Getting the error about unable to install the APE / AWS / HA.

                          Double checked  /Orion/Admin/Details/ModulesDetailsHost.aspx and confirm same versions.

                           

                          I even went and uninstalled everything that was on the additional server.

                          Tried to repair the NCM install as it hit a issue with services not stopping holding up the install, as well as crashing about 30min later [Case# 1045923]

                           

                          Got this error saying another installer was running.   However even after a reboot of the core server, then repairing NCM and NTA which I installed last, I still get incompatible modules found.

                           

                          If I remember correctly, there is a Db table that support had to assist clearing ages ago. Sound correct aLTeReGo?

                            • Re: SAM RC 6.3
                              aLTeReGo

                              squinsey can you copy/paste the footer from the Orion web interface into a follow-up post so we can verify the versions? It looks like your problem with the APE/AWS/HA installer is the version of WPM you are running. You need to be running WPM v2.2.1 (or later) to use this new installer. Note, at the time of this post WPM 2.2.1 is the latest version of WPM.

                                • Re: SAM RC 6.3
                                  squinsey

                                  Versions as shown in the bottom banner during upgrade last night. Confirmed as WPM 2.2.1, Installer signature: Saturday, 19 December 2015 1:35:29 PM
                                  And screenshot in control panel / case files.

                                   

                                  - Ran a install repair to no avail.

                                  - Downloaded and installed WPM-v2.2.1-Full.zip 764 MB (801,788,743 bytes) again.

                                       During the install is still says v2.2 however "Control Panel\Programs\Programs and Features" confirms same v2.2 // 2.2.426.1

                                   

                                  Over to the second server.

                                  Computer says    The Rubix Cube did make me smile though. Nice Easter egg

                                   

                                        ->InitialPost NPMPost SAMPost NCMPost NTA
                                  Orion2016.1.53002016.2.1002016.2.1002016.2.1002016.2.100
                                  WPM2.2.12.2.12.2.12.2.12.2.1
                                  IPAM4.3.24.3.24.3.24.3.24.3.2
                                  SRM6.3.06.3.06.3.06.3.06.3.0
                                  VNQM4.2.44.2.44.2.44.2.44.2.4
                                  NCM7.5.07.5.07.5.07.5.17.5.1
                                  NPM12.0.012.0.112.0.112.0.112.0.1
                                  DPA10.0.110.0.110.2.010.2.010.2.0
                                  QoE2.1.02.2.02.2.02.2.02.2.0
                                  NTA4.2.04.2.04.2.04.2.04.2.1
                                  IVIM2.1.22.1.22.1.22.1.22.1.2
                                  SAM6.2.46.2.46.3.06.3.06.3.0
                                  NetPath1.0.01.0.11.0.11.0.11.0.1
                            • Re: SAM RC 6.3
                              njoylif

                              working on RC2 installs.  have 12.0.0 RC installed, NCM 7.4, SAM 6.2.1, NTA 4.1.1 and just upgraded UDT to 3.2.4.

                              NPM install says not compatible w/ NCM 7.4 - has to be 7.5

                              NCM install says not compatible w/ NPM 12.0 - has to be 12.0.1....

                               

                              which came first? 

                               

                              The RCs aren't all in the upgrade advisor for me.

                              How can I proceed?