3 Replies Latest reply on Sep 20, 2016 9:42 AM by Craig Norborg

    SNMP v3 Setup not working

    rlaplante@bhfs.com

      SNMP v3 and I are NOT friends. The connection tests fail.  With router debugs enabled, the router display the following any time I test the connection.  Why would the security level be no auth from NPM when auth/priv is set?    Lost/dazed/confused.

       

      Incoming SNMP packet

      Aug  2 20:52:00.360: v3 packet  security model: v3       security level: noauth

      Aug  2 20:52:00.360: username: XXXXX

      Aug  2 20:52:00.360: snmpEngineID: XXXXX

      Aug  2 20:52:00.360: snmpEngineBoots: 0 snmpEngineTime: 0

       

      A test from MIB Walk utility produces the same failure but slightly different router output.

       

      Aug  2 21:01:28.659:

      Incoming SNMP packet

      Aug  2 21:01:28.659: v3 packet  security model: v3       security level: noauth

      Aug  2 21:01:28.659: username: XXXXX

      Aug  2 21:01:28.659: snmpEngineID: XXXXX

      Aug  2 21:01:28.659: snmpEngineBoots: 0 snmpEngineTime: 3514564

      Aug  2 21:01:28.716:

      Incoming SNMP packet

      Aug  2 21:01:28.716: v3 packet  security model: v3       security level: auth

      Aug  2 21:01:28.716: username: XXXXX

      Aug  2 21:01:28.716: snmpEngineID: XXXXX

      Aug  2 21:01:28.716: snmpEngineBoots: 0 snmpEngineTime: 3514564

       

      snmp-server engineID local XXXXX

      snmp-server group NetOPS v3 priv read NetOPSView notify XXXXX.

      snmp-server view NetOPSView dod included

      snmp-server view NetOPSView internet included

      snmp-server host 172.31.25.220 version 3 priv bhfs5nmp  config power-ethernet vlancreate vlandelete envmon stackwise errdisable

       

      User name: XXXXX

      Engine ID: XXXXX

      storage-type: nonvolatile        active

      Authentication Protocol: MD5

      Privacy Protocol: AES128

      Group-name: NetOPS