0 Replies Latest reply on Jul 5, 2016 5:50 PM by RichardLetts

    NPM 12.0 upgrade log

    RichardLetts

      Start: 0900

       

      0935: going along swimmingly,

      Some odd error message in a Command window:

      "The Service Name is Invalid"

      then it closed and went away -- this error appeared on every install.

       

      0940: "C:\inetpub\Solarwinds could not be modified (error from Configuration Wizard)

      Ran it agin

      Same error

      Rebooted the App server

      Config wizard worked this time :/

      Except it FAILED to build a web-request to the https port -- really does anyone actually test https bindings?

       

      0952: started the additional poller installs

       

      1029: started app2 upgrade (primary server in the FOE pair)

       

      1100: started the addiitional poller upgrades

      - these seemed to require more reboots of a server than I expected.

       

      1143: all upgrades finished.

       

      12:00 the informationservicev3 on two of the additional pollers (primary in a FOE pair) was crashing periodically

       

      12:15 noticed the firewall settings for RabbotMQ were incorrect (need to have the ALL profile active, because the profile they were configured on was not active)

      Also noticed the RabbitMQ port in the manual was incorrect (it says TCP/5671, it's actually on TCP 5672)

       

      messed around trying various things; the secondary pollers in the FOE pairs are working fine so

      Opened a support case

      Started gathering diagnostics

      failed over to the secondary and went for a lunch

       

      1300: ate a slice of pizza and thought about this while reading the paper

       

      1330: uninstalled all of the Solarwinds Components on the two servers; rebooted them; reinstalled everything and ran the config wizard;

      1430: all working OK;  Solarwinds support haven't called me back (I'll close the cases out shortly)

       

      1530: wrote this up