38 Replies Latest reply on Nov 1, 2016 4:59 PM by planglois

    NPM 12 Stack Data Ring error

    dan02120it

      Anyone else experiencing this error with NPM 12? The power stack data displays fine, I just get this nasty error when I add the "Stack Data Ring":

       

      Unable to construct the data ring diagram because the information required to show the diagram is missing or is not complete. Make sure the device is configured properly.

       

      This is the case for every single stack we have.

        • Re: NPM 12 Stack Data Ring error
          riley.rowe@hcfcd.org

          I just upgraded to NPM v12 and 2 of the 3 stacks are showing the same error as you are. I am looking thru the differences now to try and determine what they might be.

          • Re: NPM 12 Stack Data Ring error
            sean.herman

            Listed as known issue for old IOS versions, but I haven't personally seen it and don't know exactly which IOS version are hit by it to determine if it applies to you.

             


            Known Issues

            Cisco Switch Stacks do not provide enough data for drawing stack rings

            Issue: Some Cisco Switch Stack IOS versions do not provide enough information for drawing stack rings.

            Work-around: Upgrade the IOS on the switch stack to the latest version or contact the vendor.

            • Re: NPM 12 Stack Data Ring error
              aapereira

              I have dozens of stacks, from 2 to 8 switches.  They all report the data and power stack fine, and draw the power stack, but none of them draw the data stack ring.  Same message as above  Running a 3.6 ver

              • Re: NPM 12 Stack Data Ring error
                beardedgeeknc

                Dan,

                 

                I finally got the error message you are receiving but mine is on a stack of 9 3850s running 03.06.03E. I've checked the poller, but depending on your settings if the poller isn't assigned to that device (atleast in my setup) then the stack tab doesn't even show up. One thing I did find strange as I was investigating this was one of my stack rings is apparently not reporting/using power...more issues yay See below

                 

                #sh switch detail

                Switch/Stack Mac Address : dceb.9440.4600 - Local Mac Address

                Mac persistency wait time: Indefinite

                                                             H/W   Current

                Switch#   Role    Mac Address     Priority Version  State

                ------------------------------------------------------------

                *1       Active   dceb.9440.4600     15     V04     Ready

                2       Member   dceb.9440.4680     1      V04     Ready

                3       Member   b07d.47b7.2380     1      V04     Ready

                4       Member   bc16.f503.f800     1      V04     Ready

                5       Member   dceb.9420.fc80     1      V04     Ready

                6       Member   2834.a2fc.8680     1      V04     Ready

                7       Member   b07d.47e0.9d80     1      V04     Ready

                8       Member   b07d.47a7.cc80     1      V04     Ready

                9       Standby  dceb.9440.5080     14     V04     Ready

                 

                         Stack Port Status             Neighbors

                Switch#  Port 1     Port 2           Port 1   Port 2

                --------------------------------------------------------

                  1         OK         OK               2        6

                  2         OK         OK               3        1

                  3         OK         OK               4        2

                  4         OK         OK               5        3

                  5         OK         OK               9        4

                  6         OK         OK               1        7

                  7         OK         OK               6        8

                  8         OK         OK               7        9

                  9         OK         OK               8        5

                 

                stackdata.PNGstackpower.PNG

                sh stack-power

                Power Stack           Stack   Stack    Total   Rsvd    Alloc   Unused  Num  Num

                Name                  Mode    Topolgy  Pwr(W)  Pwr(W)  Pwr(W)  Pwr(W)  SW   PS

                --------------------  ------  -------  ------  ------  ------  ------  ---  ---

                Powerstack-1          SP-PS   Ring     4290    42      4248    0       3    6

                Powerstack-11         SP-PS   Ring     4290    34      4256    0       3    6

                Powerstack-12         SP-PS   Ring     0       0       0       0       0    0

                1 of 1 people found this helpful
                • Re: NPM 12 Stack Data Ring error
                  trmoon19

                       Actually, I'm seeing this problem on a 3850 running 03.07.04E (Paired nodes, no Stack data) and I'm missing one out of a four-node setup of 3850's running the same version.  Has anyone seen similar of late?  I've ensured that the stack poller is both compatible and applied, and that all stack related elements are being polled, but no joy.

                  1 of 1 people found this helpful
                    • Re: NPM 12 Stack Data Ring error
                      beardedgeeknc

                      tr,

                       

                      Are the switches/stack ports reporting all up on the switch side? Check provisioning as well.

                      "sh switch" and "sh switch stack-ports" should let you know that they are all connected and provisioned properly.

                      1 of 1 people found this helpful
                        • Re: NPM 12 Stack Data Ring error
                          trmoon19

                          (results: 3850 pair w/ 3.0.7.04E)

                          The Switch Stack Members pane provides data, which matches the sh switch results 1 for 1.  (hw version v02)

                          Sh switch stack-ports show both ports for both switches as OK.

                          Resources view in SW shows that both stackports are listed and polled, as well as the related StackSub resources.

                           

                          (results: 3850 quad stack)

                          sh switch has leaves 1-3 all good to go and matching each other (hw v06), but the 4th switch is version 0.  Possible problem there, even though all are listed as ready?

                          Sh switch stack-ports show both ports for all switches as OK.

                          Resources view in SW shows all four sets of stackports and StackSub resources as present and polling.

                          1 of 1 people found this helpful
                      • Re: NPM 12 Stack Data Ring error
                        planglois

                        Is there a way to not poll Stack-power but keep the data ring?  We have multiple dual-stacked 3650's. Those switches do not have the powerstack capability

                         

                        I have multiple log entries where we see that SolarWinds tries to gather the information:

                             2016-10-31 17:23:46,099 [STP SmartThreadPool Thread #199568] WARN  SolarWinds.NPM.Pollers.Technology.SwitchStack.CiscoSwitchStackPollerHelper - 10.xx.xx.xx - StackPower data was not discovered

                         

                        How could we clean this up?