22 Replies Latest reply on Mar 6, 2017 5:18 PM by foonly

    NPM 12.0 Upgrade - Website Configuration Failed

    erdemmulutas

      Hi friends,

       

      I decided to upgrade to NPM 12.0 from version 11.5.3. I followed the instructions on the upgrade guides. Everything seemed okay and installation was ended smoothly. After NPM 12.0 installation I started Configuration Wizard and an error occured in this progress.

      It promped this message:

      npm12hata.JPG

      I checked all the folder permissions for C:\Inetpub\SolarWinds.

      I also executed OrionPermissionChecker and everything seemed okay.

      Then I ran the Configuration Wizard again and still got the error.

      I also tried to stop IIS Service but Configuration Manager requires IIS to be working.

       

      So that's all. I ran out of solutions and need your valuable ideas.

        • Re: NPM 12.0 Upgrade - Website Configuration Failed
          janene16

          Do you have antivirus installed? can you temporarily stop this while running Configuration Wizard?

          Next, see to it the the local service accounts (IUSR, authenticated users, network service) have ful rights to this folder.

          Also, verify all services are stopped before running CW.

          Lastly check that no other users are logged into your server.

           

          Best of luck!

          2 of 2 people found this helpful
          • Re: NPM 12.0 Upgrade - Website Configuration Failed
            goodzhere

            Run as a local admin on the box.  Login as local admin and/or chose run as Administrator for the installer.  It should work then.  If you are running as a user in an AD group. all the local permissions might not be applied to the box.

            1 of 1 people found this helpful
            • Re: NPM 12.0 Upgrade - Website Configuration Failed
              mklemovitch

              I ran across the same error message.

               

              Tried everything listed here plus a few other places. No joy.

               

              I noticed that TrustedInstaller process was using about 2 GB of memory. Hmm, that's not normal. So I thought maybe the pending Windows Updates on the VM were locking some files. So I let Windows Update complete installing and restart the server.

               

              Sure enough, once the server restarted NPM installation went fine.

               

              Hope this solution helps somebody else avoid the hour of troubleshooting it took me to figure this out.

              2 of 2 people found this helpful
              • Re: NPM 12.0 Upgrade - Website Configuration Failed
                chippershredder

                For me, none of these solutions worked.

                - Run configuration wizard as Admin (I always do this for all application executions)

                - permission NETWORK SERVICE on c:\inetpub\Solarwinds (permissions were correctly set)

                - stop HTTPS redirection (was not set for me)

                - shutdown all poller services (all services were shut down on both servers)

                 

                My server is a Windows 2012 R2 running NPM 11.5.3 and SAM 6.2.3.  McAfee security services were set to maintenance prior to the install of NPM 12.  Ran the installer as admin, copying files completed and then automagically ran the configuration wizard.  Right after the FIPS check, error showed access denied failure trying to configure the website.  I reran the configuration (as admin) thinking there may have been a flaky condition, same conditions.  Restarted the machine and reran the configuration wizard, but same results.

                 

                HERE IS WHAT WORKED FOR ME:

                - In IIS manager, I did not have a binding for http (only https)

                - Add the Solarwinds site http binding with the server hostname and all IP addresses

                 

                I do not have the opportunity to work through this differently to determine if the https binding (no hostname and specific IP) is the issue.

                 

                I am happy to here comments from all Thwackers!  Thanks!

                2 of 2 people found this helpful
                  • Re: NPM 12.0 Upgrade - Website Configuration Failed
                    chippershredder

                    Follow up:

                     

                    After completing the product updates on both my servers (configuration wizard ran without issue on the secondary system), I removed the http binding from SolarWinds NetPerfMon and restarted the site.  There have been no ill effects and the system appears fully operational.  Users are able to connect and navigate as permissions allow.

                     

                    I am going to chalk this one up to government (in)efficiency and STIG compliance. 

                     

                    Now on to better, more interesting things!

                  • Re: NPM 12.0 Upgrade - Website Configuration Failed
                    rlaplante@bhfs.com

                    Same Issue.  All that I did was add the NETWORK SERVICE user with full rights based on another thread for a previous version.

                    1 of 1 people found this helpful
                      • Re: NPM 12.0 Upgrade - Website Configuration Failed
                        stevengj1

                        This worked for me add NETWORK SERVICE user to the inetpub directory. The weird thing is, this was on may additional server after applying OrionPlatform-v2016.1.5300-HotFix1.   On the main server the upgrade went fine and on the add't web server the upgrade went fine. I had the problem after Hotfix 1. I also let web optimization go through completely.  The first time I stop the optimzation.

                      • Re: NPM 12.0 Upgrade - Website Configuration Failed
                        sstark85

                        Adding an HTTP port 80 binding in IIS fixed this access denied issue for me..

                        3 of 3 people found this helpful
                        • Re: NPM 12.0 Upgrade - Website Configuration Failed
                          foonly

                          I am getting this after running NPM-v12.0.1-HotFix1 and installing SAM 6.3 and its hotfixes 1 and 2.

                           

                          I think in my case, the config wizard took so long to launch on my 32CPU 96GB PowerEdge 720 , that I thought it was not going to run. I removed the HTTP site the Wizard added, and went on to my next install, and then the Wizard popped under in the background. I didn't see it till much later. It would be good if the main installer GUI would not exit until that last wizard starts and finishes.

                           

                          Like more and more customers, we do not use HTTP. We have a government issued SSL cert, and configure only HTTPS in IIS, with an FQDN. The security folks don't want us to have any HTTP binding or redirect.

                           

                          The Config Wizard has always insisted on adding an HTTP site (well, for the last 10 years or so). This breaks many other things like URLs in alerts, so we constantly have to edit the WebSites table to deleted to HTTP site and make the HTTPS site primary. The Skip HTTP Binding Option of the Config Wizard has never worked.

                           

                          What is the Skip HTTP Binding Option?

                           

                          The Wizard still adds a web site on port 80 with just the hostname, and makes it Primary. It does leave the original site with the FQDN and port 443 and SSL set to 1 there as a Secondary.

                           

                          I would caution any of you who granted NETWORK SERVICE rights to the whole directory, and have your web server facing the internet. If an IIS exploit comes up, you may find the hacker gets much more access to your server and your company. There's a reason why so many rights are specific in IIS.

                           

                          =Foon=