8 Replies Latest reply on Dec 14, 2016 10:56 AM by twin--turbo

    HP Comware 7 Switches

    idm24@cam.ac.uk

      I have been using CatTools successfully with Cisco and HP Procurve switches for some time now, but I can't get the software to successfully talk to a new Comware switch. Looking at the debug logs it looks like it isn't coping with the default Comware prompt format e.g. <sysname> or [sysname] for user or system view respectively. Any idea what I need to do to get it to work?

       

      Thanks

       

      iain

       

      ps I have logged a call with SolarWinds but this is proving to be a soul destroying process. The case is flagged as not started after two days, I've left answer phone messages to no avail and listened to muzak for far too long.

        • Re: HP Comware 7 Switches
          bkyle

          Which device type are you using?  Also, have you used Variations to modify the prompt?

            • Re: HP Comware 7 Switches
              idm24@cam.ac.uk

              Hi,

                I'm using HP.Switch.Others and model 5900. If I use Variations it seems to work, but I really don't want to set up variations for every switch in our new building or have things break because a switch is renamed. In my view the parsing/prompt construction logic is broken and needs to be fixed. If this was freeware I'd be happy to bodge things, but as this is a commercial bit of software it should work.

               

              thanks

               

              iain

            • Re: HP Comware 7 Switches
              bkyle

              Variations can provide a work around until the device has been added to CatTools.

              • Re: HP Comware 7 Switches
                bkyle

                Can you sanitize a debug file and post it here?

                  • Re: HP Comware 7 Switches
                    idm24@cam.ac.uk

                    Of course

                     

                     

                    <NEWSESSION CatTools 3.11.0 31/05/2016 14:25:02>

                    <PROTOCOL=SSH2>

                    <DEVICE TYPE=HP.Switch.Others>

                    <ACTIVITY TYPE=Device.Backup.Running Config>

                    <ACTIVITY SCRIPT=C:\Program Files (x86)\CatTools3\Scripts\Client.Device.Backup.Running Config.txt>

                    <USERS NAME FOR DEVICE=Core>

                    <C OK 14:25:03>

                    <R-14:25:03>Last login time: Tue Jan 11 04:01:03 2011[13][10][13][13][10]

                    <R-14:25:04>[13][13][10][00]******************************************************************************[13][13][10]* Copyright (c) 2010-2014 Hewlett-Packard Development Company, L.P.          *[13][13][10]* Without the owner's prior written consent,                                *[13][13][10]* no decompiling or reverse-engineering shall be allowed.                    *[13][13][10]******************************************************************************[13][13][10][13][13][10][00]

                    <R-14:25:04><sw-c-ls (Core Lab South)>

                    <W-14:25:04>[13]

                    <R-14:25:05>[13][13][10]<sw-c-ls (Core Lab South)>

                    <W-14:25:05>screen-length disable

                    <R-14:25:05>screen-length dis

                    <R-14:25:05>a

                    <R-14:25:05>b

                    <R-14:25:05>le

                    <W-14:25:05>[13]

                    <R-14:25:05>[13][13][10]<sw-c-ls (Core Lab South)>

                    <W-14:25:05>[13]

                    <R-14:25:05>[13][13][10]<sw-c-ls (Core Lab South)>

                    <W-14:25:05>system-view

                    <R-14:25:05>system-view

                    <W-14:25:05>[13]

                    <R-14:25:05>[13][13][10]System View: return to User View with Ctrl+Z.[13][13][10][sw-c-ls (Core Lab South)]

                     

                    ================================================================================

                    WFMDRetVal=1 Waiting for: "<sw-c-ls (Core Lab South)]"

                    WFMDRetVal=2 Waiting for: "<sw-c-ls (Core Lab South)>"

                    WFMDRetVal=3 Waiting for: "Password"

                    WFMDRetVal=4 Waiting for: "login as:"

                    WFMDRetVal=5 Waiting for: "[y/n]"

                    WFMDRetVal=6 Waiting for: "[Y/N]"

                    WFMDBuffer="[13][13][10]system view: return to user view with ctrl+z.[13][13][10][sw-c-ls (core lab south)]"

                    ================================================================================

                    <R-14:35:06>[13][13][10]Inactive timeout reached, logging out.[13][13][10]

                    <D 14:35:06>

                    <SCRIPT VALUES>

                    <HOSTNAME="<sw-c-ls (Core Lab South)">

                    <PROMPT VTY="<sw-c-ls (Core Lab South)>">

                    <PROMPT ENABLE="<sw-c-ls (Core Lab South)]">

                    <PROMPT CONFIG="<sw-c-ls (Core Lab South)]">