11 Replies Latest reply on Aug 3, 2016 4:49 PM by tbone1985

    CatTools and SonicWall 6.2

    tbone1985

      Trying to get my SonicWall firewall NSA5600 config to back up via CatTools.  Seems that everything I try doesn't work.  It's trying to enter the wrong commands for displaying the current config.

       

      Anyone else having these issues?

        • Re: CatTools and SonicWall 6.2
          bkyle

          You can edit the device , and  use the Variations option.  Go to the Additional Commands tab, check the Show Running Config box, and enter the correct command.

            • Re: CatTools and SonicWall 6.2
              josealconchel

              is there a guide or anything on how to do that? I'm thinking abut getting this software for my company but for me it's key to be able to backup SW and if it's going to take me hours of research then it's not worthy...

               

              Capture.PNG

               

              After runnung backup the backup file content this:

               

              % Error encountered at '^' marker:

                  show all

                       ^

              % No matching command found.

               

               

              Thanks in advance.

            • Re: CatTools and SonicWall 6.2
              bkyle

              What is the command that you use to see the config from a command line?  It appears that sh all is incorrect.

              • Re: CatTools and SonicWall 6.2
                bkyle

                I should, depending on the firmware version.  Can you connect via Putty, and the post a screenshot of the prompts?

                • Re: CatTools and SonicWall 6.2
                  bkyle

                  Can you enable capture mode (File\Enable capture mode), remove sensitive information, and post the debug file that is located in your  \CatTools3\Debug folder?

                    • Re: CatTools and SonicWall 6.2
                      tbone1985

                      <NEWSESSION CatTools 3.11.0 7/25/2016 9:28:23 AM>

                      <PROTOCOL=SSH2>

                      <DEVICE TYPE=SonicWall.SonicOS>

                      <ACTIVITY TYPE=Device.Backup.Running Config>

                      <ACTIVITY SCRIPT=C:\Program Files (x86)\CatTools3\Scripts\Client.Device.Backup.Running Config.txt>

                      <USERS NAME FOR DEVICE=SonicWall>

                      <C OK 9:28:23 AM>

                      <R-9:28:23 AM>[13][13][10]                                                                      [13][10]Copyright (c) 2016 Dell | SonicWALL, Inc.                             [13][10]                                                                      [13][10]                                                                      [13][10][13][13][10]Using username 'admin'.[13][10]Password:[13][10][13][10]admin>

                      <W-9:28:23 AM>admin

                      <R-9:28:23 AM>admin

                       

                       

                      ================================================================================

                      WFMDRetVal=1 Waiting for: ">"

                      WFMDRetVal=2 Waiting for: ">"

                      WFMDRetVal=3 Waiting for: "User:"

                      WFMDRetVal=4 Waiting for: "Password:"

                      WFMDBuffer="admin"

                      ================================================================================

                    • Re: CatTools and SonicWall 6.2
                      bkyle

                      Please post a screenshot of you prompts tab, and the prompts tab of Variations if used.

                      • Re: CatTools and SonicWall 6.2
                        tbone1985

                        So I got this to work by chatting with support.  We ended up having to set some parameters in variations.  Hope this helps:

                         

                         

                         

                        1 of 1 people found this helpful