1 Reply Latest reply on Jul 13, 2016 4:37 AM by chriho

    FTP Voyager Scheduler & Daylight Saving Time Issues

    gkuftin

      Our servers are in a MS Active Directory Domain and running FTP Voyager version 16.2.0.328.  It seems that FTP Voyager Scheduler doesn't like Daylight Saving Time too much.  A year or two ago my scheduled jobs got corrupted and I had to recreated them all over again.  Since I have been scheduling the service to stop @ 1:50 a.m. and then restart @ 3:10 a.m..  Back in November 2015 this worked out well.  This last Sunday when the time changed again a few of the servers repeated sent out the same notifications over and over again (hundreds).  The last time the problem occurred the FTP Voyager Scheduler icon in the system tray would alternate between green and blue, indicating that a job was running.  This time the icon stayed green.  I have disabled the Scheduler service but am still receiving earlier notifications.  Is the avalanche of notifications the fault of FTP Voyager Scheduler (this time) or our mail server in response to the time change?  Any help would be greatly appreciated.

       

      Greg

        • Re: FTP Voyager Scheduler & Daylight Saving Time Issues
          chriho

          Hi Greg,

           

          better late than never ... We have the same problem here. I cannot present a solution, but a workaround. I too stop FTP Voyager Scheduler in the evening before Daylight Saving Time starts or ends. The day after, I open the file Scheduler.Archive (in ..\Programs\RhinoSoft\FTP Voyager\) in an editor. Then I search for "next run time". The entry "Val" contains the timestamp for next runtime in unix-format (seconds from 1970-1-1). You can charge the current time or the time, when the task should run for the next time on

          http://7070.org/docs/timestamp . After you changed the value for each task, you can start the Scheduler again - and it should work without problems.

          This also works if the Scheduler still runs when DST starts or ends. In this case you have to stop the Scheduler (and / or the service, if it runs like this) and change the value.

           

          BR

          Christoph