0 Replies Latest reply on Mar 11, 2016 4:35 PM by jhungerford8887

    Pre package install question

    jhungerford8887

      I wrote a bat file to copy a dll to a location on a pc when a java patch was pushed out.  I cant seem to get it to copy the dll.  I have told it to pull from package directory to for the information. 

       

      right now my bat file is looking like this

       

      copy "x" C:\Program Files (x86)\x\x\x

       

      Is there anything else I need to do with the patch manager.

       

       

      -<packageboot version="2.0.0.0"id="dd53b76e-babc-410f-8901-426d0989f5f1">

       

       

       

       

      -<instructions>

       

       

       

       

      -<preexecution>

       

       

       

       

      -<services>

       

       

       

       

      <service failureaction="stop"enabled="true"name="javaquickstarterservice"action="stop"/>

       

       

      </services>

       

       

      -<programs>

       

       

       

       

      <program failureaction="stop"enabled="true"name="imm.bat"type="exe"typeaction="runandwait"successcode="0">/s</program>

       

       

      </programs>

       

       

      -<processes>

       

       

       

       

      <process failureaction="stop"enabled="true"name="iexplore.exe"action="terminate"/>

       

       

       

      <process failureaction="continue"enabled="true"name="java.exe"action="terminate"/>

       

       

       

      <process failureaction="continue"enabled="true"name="jp2launcher.exe"action="terminate"/>

       

       

      </processes>

       

       

      -<filesinuse>

       

       

       

       

      <fileinusecheck enabled="true"terminateinuseprocesses="true"type="simplepath"path="%PROGRAMFILES%\Java\jre8\bin"checkonlydllsandexes="true"/>

       

       

       

      -<fileinusecheck enabled="true"terminateinuseprocesses="true"type="simplepathlist"path="%PROGRAMFILES%\Java\jre8\bin\server">

       

       

       

       

      <file>jvm.dll</file>

       

       

      </fileinusecheck>

       

      </filesinuse>

       

      </preexecution>

       

       

      -<execution>

       

       

       

       

      -<programs>

       

       

       

       

      <program failureaction="stop"enabled="true"name="jre-8u73-windows-x64.exe"type="exe"typeaction="runandwait"successcode="0">/s</program>

       

       

      </programs>

       

      </execution>

       

       

      -<postexecution>

       

       

       

       

      -<programs>

       

       

       

       

      <program failureaction="stop"enabled="false"name="postprogram.exe"type="exe"typeaction="runandwait"successcode="0"> </program>

       

       

       

      <program failureaction="stop"enabled="false"name="wusa.exe"type="exe"typeaction="sleepandrun"sleeptime="60"pathtype="simplepath"path="%windir%\system32">%MODULEPATH%\Windows6.0-KB968930-x86.msu /quiet /norestart</program>

       

       

       

      <program failureaction="stop"enabled="false"name="helper.exe"type="exe"typeaction="runandwait"pathtype="regprependpath"regpath="HKEY_LOCAL_MACHINE\SOFTWARE\Mozilla\Mozilla Firefox\3.0.14 (en-US)\Uninstall"regvalue="Uninstall Log Folder"successcode="0">-S</program>

       

       

      </programs>

       

       

      -<services>

       

       

       

       

      <service failureaction="continue"enabled="false"name="someservice"action="start"/>

       

       

      </services>

       

      </postexecution>

       

      </instructions>

       

      </packageboot>