5 Replies Latest reply on Jan 11, 2017 10:03 PM by ktuter

    NCM fails with "Transfer Setup Error"

    Anthony Ussery

      Good morning,

       

      I'm having an issue using NCM in the Edit Properties screen.  My primary poller shows a Down state under the Change Polling Engine dialog, and if you try to test your Connection Profile under NCM Properties, it fails with the error message "Test Failed. Transfer Setup Error"

       

      What do I need to do in order to fix my primary poller?

        • Re: NCM fails with "Transfer Setup Error"
          dustin.ampania

          I've experienced the same issue. Because the latest patch broke my automated backup jobs I now run the backups manually. Last week a large selection of nodes failed with the error message 'Transfer Setup Error' all of which occurred to nodes on a specific poller. I moved the nodes off that poller and they were able to backup successfully. Today I'm experiencing the same issue on another poller, but I'm going to wait to appy the hotfix that was released last week before moving any additional nodes. I'd be really nice if one upgrade would go smoothly without introducing new show stopping bugs.

          1 of 1 people found this helpful
          • Re: NCM fails with "Transfer Setup Error"
            ktuter

            Greetings,

             

            I also ran into the "Transfer Setup Error" from my primary poller but from my APE the connection is successful.  I did some digging and found some clues but I don't know exactly yet what is causing the issue.  Maybe by posting what I found someone with more Windows savvy can find the root cause.

             

            In the NCM log file NcmBusinessLayerPlugin there is an error that looks like this:

            2017-01-11 22:56:27,193 [22] INFO  SolarWinds.NCM.Transfer.TransferSetupHelper - NCMTransfer IP:xxx.xxx.xxx.xxx applying connection profile TACACS SSH

            2017-01-11 22:56:27,208 [22] ERROR SolarWinds.NCM.Transfer.TransferSetupHelper - NCMTransfer IP:xxx.xxx.xxx.xxx - Setup Session ErrorSystem.IO.FileNotFoundException: Creating an instance of the COM component with CLSID {69251387-0BFD-4780-BE5E-D2E6492F6C42} from the IClassFactory failed due to the following error: 8007007e The specified module could not be found. (Exception from HRESULT: 0x8007007E).

               at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)

               at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)

               at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache, StackCrawlMark& stackMark)

               at System.Activator.CreateInstance(Type type, Boolean nonPublic)

               at System.Activator.CreateInstance(Type type)

               at SolarWinds.NCM.Transfer.TransferSetupHelper.CreateSession(TransferNode node, DeviceCommands commands)

             

            ConnectionTester.exe Run-Time Error:

            So I looked around around at some NCM tools and found there is a ConnectionTester.exe tool that is used to test Telnet and SSH connections from the Polling host.  I tried to launch this tool and found that it also gave an error from my primary poller but works fine from my APE.

             

            ConnectionTester.exe_runtime_error.JPG

            So either the TransferSetupHelper uses the ConnectionTester.exe or some module that both of them rely on is not available or registered correctly.  Someone with more Windows savvy might be able to dissect the ConnectionTester.exe and determine what it is needing that is missing.  I tried copying the ConnectionTester.exe from a working poller thinking it might be a corrupt file but the result was still the same.

             

            Anyone have an idea what this can be?  I have also submitted a ticket with Solarwinds but sometimes the community is faster at finding a resolution.

             

            Thanks!