cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 8

processor monitor not working on one server

Hi,

On one server (win2k) the processor monitor seems not to work, if I delete the processor monitors then re-add they work for a week or so then go red with this error:

The remote device provided an empty list of values

Any ideas what this could be?  I've restarted snmp and re-installed snmp informant.

 Thanks.

0 Kudos
4 Replies

I have the same problem, using ipMonitor v10.0 and SNMP host MIB, and it happens often. Is this going to be fixed permanently by SolarWinds?

I tried to work around it by specifying a "Processor Total" monitor, but this will not work for single CPU servers, which is kind of odd, since the Processor Total is measuring the average of hrProcessorLoad.* (at least that's what I make of it from reading this post: )

It seems that ipMonitor is forcing the user to select a specific CPU (which is apparently changing), and only offer the Total for multiple processor systems.

Windows perfmon can show a "_Total" valuefor single CPU systems... why can't ipMonitor measure the "average of one" ?!

0 Kudos
Level 7

Hello,

I had the same problem with the memory and CPU monitors on a (Win2K8_SP2) server.  In my case it turned out that the WMI service was hung and giving no warning to the OS.  After restarting the service the effected monitors came back online. Hope this helps someone.

 

-RS

0 Kudos
Level 9

Did the server reboot before this happened? I had the same problem with two of our Server 2000 boxes and it happened when they rebooted. I would have to go into the monitor and click the "Select" button to reselect the CPU again. For some reason after reboot something would happen to where the id changed or something and I would have to reselct it within the monitor. 

0 Kudos

 It worked!

 

Thanks for the reply.

0 Kudos