cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

JDBC connection not successful after upgrade to WHD 12.7.1

OS: CentOS 7, fully updated

WHD version initial (working): 12.5.1.88

WHD version after upgrade (broken): 12.7.1.538

JDBC connector: mysql-connector-java-8.0.18.jar

JDBC (also tried old version): mysql-connector-java-5.1.48.jar

Path for JDBC: /usr/local/webhelpdesk/bin/jre/lib/ext/

Also tried path: /usr/local/webhelpdesk/bin/webapps/helpdesk/WEB-INF/lib/

Issue:

I have a working install of Web Help Desk 12.5.1.88, using an external mySQL database with a JDBC connector. I upgraded to WHD 12,7,1, following the upgrade documentation, and installing the latest JDBC jar file in the path specified in the documentation. After upgrading to WHD 12.7.1,538, WHD is no longer able to find or use the JDBC to connect to the database.

log/helpdesk.log shows the following error, iterating per unique daemon:

WARN  [2019-12-12 10:05:59]<CommonDaemonExecutor-thread-1> Invalid database connection...

INFO  [2019-12-12 10:05:59]<CommonDaemonExecutor-thread-1> Running daemon 'ApprovalReminderDaemon'...

INFO  [2019-12-12 10:05:59]<CommonDaemonExecutor-thread-1> Asserting connection with jdbc:mysql://localhost:3306/whd...

INFO  [2019-12-12 10:05:59]<CommonDaemonExecutor-thread-1>   url: jdbc:mysql://localhost:3306/whd

ERROR [2019-12-12 10:05:59]<CommonDaemonExecutor-thread-1> Exception while asserting connection: com.macsdesign.util.MissingJdbcDriverException: Unable t

o locate the MySQL JDBC driver required for the database connection.

log/whd-spring.log shows the following error, listing further failure details after it:

2019-12-12 10:05:52.336 [ApplicationManager-1]  INFO c.s.c.WhdPersistenceComponentConfig - Initializing DB: MYSQL on jdbc:mysql://localhost:3306/whd

2019-12-12 10:05:52.615 [ApplicationManager-1]  INFO c.s.c.WhdPersistenceComponentConfig - Max number of active DB connections is set to 10

2019-12-12 10:05:52.634 [ApplicationManager-1]  WARN c.s.c.WhdPersistenceComponentConfig - Failed to connect to DB: org.apache.commons.dbcp.SQLNestedException: Cannot load JDBC driver class 'com.mysql.jdbc.Driver'

2019-12-12 10:05:55.423 [ApplicationManager-1] ERROR c.s.w.s.a.i.WhdApplicationManagerImpl - Failed to start WHD application. Reason: DB_CONNECT_FAILED

org.apache.commons.dbcp.SQLNestedException: Cannot load JDBC driver class 'com.mysql.jdbc.Driver'

I've also tried the older version of JDBC (5.1.48) in the documented JDBC path, just to try it.

Should the JDBC jar live in a different path under WHD 12.7.1?

Does WHD 12.7.1 remove compatibility with JDBC?

JDBC 8.0.18 documentation states it is compatible with OpenJDK 11.

Your input is welcomed - thanks!

0 Kudos
3 Replies
Level 7

Just wanted to follow up:

The problem turned out to be that the upgrade fails when using rpm -U webhelpdesk-*.rpm. The upgrade succeeds when using yum install webhelpdesk-*.rpm. Outrageously obvious, in hindsight.

0 Kudos
Level 14

Looks like it needs to be installed in a different location now. See this KB article Success Center

0 Kudos
Level 7

Hi typhoon87, thanks for your reply. I did install the JDBC connector jar at the new location, and received the same error. (See above: Also tried path: /usr/local/webhelpdesk/bin/webapps/helpdesk/WEB-INF/lib/)

0 Kudos