cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

Credential Used Value on Virtualization Polling Settings Webpage

Credential Used Value on Virtualization Polling Settings Webpage

0 Kudos

We don't actually have vMAN but do use the free, teaser features of vMAN provided with NPM.  Currently I have a project where I am cleaning up our Nodes and as such, am trying to add them in a different way than I have in the past.  Rather than just adding vCenters, ESX servers and VMs through Add Node on the Manage Entities page, I am adding them by selecting them from the Virtualization - Summary webpage and starting the process there.  I am doing this because I saw some cases where the vMAN components did not link Nodes I had added to their respective designation on the Virtualization - Summary webpage.

I should also add that we only monitor our critical servers in Orion so not all discovered ESX Server and VMs on the Virtualization - Summary webpage get related Nodes in our Orion environment (ie:  It is not just a blanket add of all discovered servers).

Using this method, I ran into something that raised some concerns.  I would select to Manage an ESX server from the Virtualization - Summary webpage, go through the process successfully and, once completed, on the Virtualization Polling Settings page, the server would be listed along with the creds I used in the Credential Used column.  Perfect...  However...

Next I would edit the Node and once completed, the Credential Used column no longer listed the creds I used next to that server.

I did open a Support case and was told this was expected behavior.  That if the creds I used matched those of the parent vCenter, the creds would only be listed with that vCenter.  My concern was that I have seen other places in Orion where data can go stale.  For example, if you are monitoring a server using WMI including HWH, when you change to the ICMP Polling Method, the HWH stays in the state it was before the Polling Method change even though that might not be the current status of the HWH sensor.

Digging into the database for this Credential Used situation I found that the field that would normally hold that cred is NULL.  Making me even more concerned.  However I also did find that the data in the database was being updated which eased my mind.

However, back to the Virtualization Polling Setting page, because there is nothing listed in the Credential Used column I don't know if that is because it is using the vCenter creds or because no creds have been assigned.  It would seem more logical to me if SW would either listed the vCenter cred next to that ESX server in the Credential Used column or something like "Using vCenter Credentials" so that this is much clearer and avoids the confusion I had.

If you agree, please up-vote this FR.

 

THANKS

Mike

Tags (2)
3 Comments
Level 12

Let me add that when I edit the Node, as mentioned above, I don't need to change any data.  When I hit SUBMIT, the Credential Used disappears.  If I hit CANCEL instead, the Credential Used remains.  It seems to remain in that column until the Node is edited and SUBMITted.

 

To me that just makes no sense.

Level 7

SolarWinds marks, identified on the SolarWinds website, as updated from hese credentials will be used during and after SolarWinds SAM deployment. Additionally, switching a node that was originally setup to poll with WMI (and have Event Log (Windows API) Value changed : Faulting application wmiprvse.

 

 

 

 

NavyArmyCCU Login

Level 12

@Brantley156 sorry but I don't understand your reply.  I am not talking about SAM deployment or switching from WMI Polling.  Can you elaborate?