Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

UDT not working with Juniper EX-2300 series

We have a fairly large deployment of Juniper access layer switching that until about a year ago was mostly the EX2200 series. Over the last year and a half we've started using the EX2300 series and unfortunately cannot get UDT working. As we continue to lifecycle devices our population of the 2300 series switches has increased greatly and not being able to use UDT on these devices is frustrating.

Last year we contacted both Solarwinds support and Juniper about this and what we found is that Juniper changed OIDs somewhere between the EX2200 series we have running OS 12.x to the EX233 series we are now getting running OS 15.x. This is also causing issues with vlan polling.

Has anybody else ran into this issue and if so what are you doing about it? Solarwinds asked us to submit a feature request for this which we did, but that was a year ago and Juniper has also not been able to help. Within another year or two we'll have refreshed all of our devices and if this is still not working UDT will become completely useless to us.

Forgot to mention that this will not work with on any Juniper ELS devices. With everything in their product line heading this way I would hope something will change to get this working in the near future.

Tags (1)
4 Replies
Product Manager
Product Manager

We could use your help!

We're missing some vital information in order to get this fixed. I'd like to ask anyone who has one of these devices (Juniper EX-2300 running Os 15+) to use the SolarWinds SNMP Walk Tool​​ to collect the MIB database and send me the results.

An SNMP walk is a simple way to set up the collection of information from routers, switches, or other SNMP enabled devices. The SNMP walk will allow us to see all of the OID parameters available on the device so that we can build new features pertaining to those devices.

The easiest way to get me the files is probably email. Please send files to, and include your THWACK username in the email to receive 250 THWACK points!

Thanks in advance for your help!

0 Kudos
Level 16

You just described the pain of SNMP...

Just 1 oid miss placed and you can’t do anything with that software...

Snmp is on the way to retirement.

RFC 1213 - Management Information Base for Network Management of TCP/IP-based internets: MIB-II

I hope the PM start looking into netconf that the way to go will work with any JunOS and modern Cisco

YANG, NETCONF, RESTCONF Demos. Which Cisco devices are supported? (Part 1) - David Bombal

0 Kudos
Level 7

Just wanted to bump this to mention that there is still no support for the Juniper ELS line of devices. As our network environment is now more than 65% composed of these devices we are starting to explore alternatives to Solarwinds. Is there nobody else experiencing this?

0 Kudos

I definitely have run into it in the past.  It was at least a year ago so I don't remember the exact details but I remember we spent a ton of time snmpwalking different Juniper models before we pinned down which oid's we were missing and I believe we were able to rig up a solution that was good enough for the client at the time, but I don't recall off the top of my head the actual details of what we came up with.  But yes, this is a "known" issue and Orion natively was not happy about it.

- Marc Netterfield, Github
0 Kudos