cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

Application Templates custom credentials for SNMP pull credentials from the SNMP list and not the windows list of credentials

Application Templates custom credentials for SNMP pull credentials from the SNMP list and not the windows list of credentials

When creating an application template and assigning groups of nodes, the only option for assignment of custom credentials pulls from the list of Windows credentials.  This does no good when polling via SNMP.  It should be pulling from the SNMPv3 credentials list.

pastedImage_1.png

6 Comments
Product Manager
Product Manager

Today SNMP Credentials are inherited from the node they're assigned. This leads us to the following existing feature request:

Level 11

Then why is there an option under SNMP to assign custom credentials (reference the above screenshot to see)?  And why are those NOT SNMP credentials?  Thanks.

Product Manager
Product Manager

SAM's SNMP Component Monitors have no Credential fields. There is nowhere to either select existing credentials nor enter new ones.

pastedImage_0.png

Level 11

It is when you apply the Application Template to a group or Node that it asks.  Did my screenshot not show up in my original post.  I see it on my screen.  I will post it again.  If you go to your application template and click assign to node, choose your node and then click Next the following show up.  This is what I am referring to:

pastedImage_0.png

Product Manager
Product Manager

The template assignment wizard is generic and has no understanding of which component monitor types exist within the application template you assigned. You would still encounter this screen even if your application template consists solely of TCP Port Monitors, which also have no authentication/credentials.

Community Manager
Community Manager
Status changed to: Open for Voting