cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 9

Version compatibility

Jump to solution

Are there any compatibility issues if I upgrade to 6.7 RC2 and my agents are still version 6.3?

I would upgrade these as well, I just wondered if I'd encounter issues immediately.

Edit: This was answered by jhynds elsewhere -- there is no issue and the agents upgrade automatically with the appliance.

0 Kudos
1 Solution

Hey Msinger,

Here in support, we will have you wait for all agents to upgrade in only very specific circumstances. For example, when upgrading from 6.2.1 to 6.3.1 we advised everyone to wait until all the agents we upgraded to 6.3.1 before progressing to the 6.4 upgrade. We did a pretty good overhaul on the agents back end code and communication channels from 6.2.1 to 6.3.1. And we wanted to ensure that all those agents got the needed platform files that the 6.4 + agents will need to function correctly. As for the upgrade to 6.7 there has been no reported compatibility or upgrade issues. Personally, knowing the major changes we have made to the 6.7 agents, it's possible that future upgrades will suggest making sure everything is 6.7 before upgrading but that is still currently just an assumption.

Thank you

Please let me know if I can help with anything else!

Your Friendly Neighborhood SolarWinds Support Tech!

View solution in original post

0 Kudos
3 Replies

Hey Msinger,

Here in support, we will have you wait for all agents to upgrade in only very specific circumstances. For example, when upgrading from 6.2.1 to 6.3.1 we advised everyone to wait until all the agents we upgraded to 6.3.1 before progressing to the 6.4 upgrade. We did a pretty good overhaul on the agents back end code and communication channels from 6.2.1 to 6.3.1. And we wanted to ensure that all those agents got the needed platform files that the 6.4 + agents will need to function correctly. As for the upgrade to 6.7 there has been no reported compatibility or upgrade issues. Personally, knowing the major changes we have made to the 6.7 agents, it's possible that future upgrades will suggest making sure everything is 6.7 before upgrading but that is still currently just an assumption.

Thank you

Please let me know if I can help with anything else!

Your Friendly Neighborhood SolarWinds Support Tech!

View solution in original post

0 Kudos
Level 12

Hi,

if I'm right you upgraded LEM manager from 6.3 to 6.7. Although you didn't see any issues, next time I'd recommend that you follow recommended upgrade path Upgrade Paths for Versions Prior to 5 4

Milan

0 Kudos
Level 9

I actually haven't upgraded yet, but yes I saw that I need to go from 6.3 to 6.4 to 6.7

Thanks!

0 Kudos