cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 7

Database Vendor Code: -1301 & cannot telnet port 9001 from local server

Hi Experts

i cannot run the report and it gives the error logon failed . SWLEMReports.log shows erro 1301 . when i started troubleshooting according to this link

Logon Failed. Database Vendor Code: -1301 - SolarWinds Worldwide, LLC. Help and Support

i cannot telnet my application with port 9001 from local server .

please help me to solve the issue .

0 Kudos
15 Replies
Level 8

0 Kudos
Level 15

Please try the following:

  1. SSH into the LEM
  2. Go to the SERVICE menu
  3. Run the UNRESTRICTREPORTS command

Does that change anything when you try to telnet or run Reports?

thanks Curtisi

i already done that but was not successful .

0 Kudos
Level 10

If you can't telnet with port 9001, it indicates something is blocking the connection through that port. Have you checked to make sure that there isn't anything blocking the connection?

Thank you Silverwolf for the information .

but i tried from local server which is in same Vlan which is not touching external firewall and there is no service running of windows firewall or antivirus .

0 Kudos

What do you have for the manager configuration? is TLS enabled? or disabled?

0 Kudos

TLS is disabled i checked on both enable and disable but didn't worked.

0 Kudos

What does it say in the crystaljrc.log in c:programfilesx86\solarwinds Log and Events Manager reports?

0 Kudos

Below is the log of crystalijrc.log

tring: jdbc:hsqldb:hsql://192.168.0.48:9001/alertdbLucius, user id: admin, password: ******, binary data: 20

04 Jul 2017 08:00:45 [ORBacus:ThreadPerRequest:Dispatcher] INFO  com.crystaldecisions.data.jdbc - languageCode: 45

04 Jul 2017 08:00:46 [ORBacus:ThreadPerRequest:Dispatcher] FATAL com.crystaldecisions.data.jdbc - SQL Exception: [SQL State:]  08001   [Error Message:]  java.net.ConnectException: Connection refused: connect

04 Jul 2017 08:00:46 [ORBacus:ThreadPerRequest:Dispatcher] FATAL com.crystaldecisions.data.javaserver - Return error value in dispatcher's DbLogonServer().  The error code is: 13

0 Kudos

Hmm It looks like you're getting "connection Refused: Connect" error. This is most likely the TLS.

I would say carry out the steps for generating the certificate needed, and import the cert to the Reports console, and enable TLS, then save those changes, close the Reports console, and then open it again as admin and test again.

Here are steps to generate the cert.

Use TLS communication in the Reports Console - SolarWinds Worldwide, LLC. Help and Support

0 Kudos

i follow the above procedure . enable tls ,no option for selecting 3 generated . manager restarted .

login to web console there is no certificate checking . i then export cert from manager manually imported to reports but the same error.

0 Kudos

Hmm strange, since it does look like the connection is being rejected. connection Refused: Connect

I'm sorry, I can't think of anything else at the moment. It might be best to reach out to the Solarwinds Support they may have more steps.

Thank you silverwolf

i already done that but now as per your instruction i will do it again . and will be back shortly .

0 Kudos

I am also getting same error. is there anyone able to fix this???

0 Kudos

Hello,

I would try to run ENABLETLS and DISABLETLS in CMC (yes, please run enable and disable). Then you should be able to connect with Reports to SEM via the non-trusted channel. If you need the trusted connection, run ENABLETLS in CMS, export the certificate from the manager and import it into the Reports console and connect using TLS connection.
Documentation can be found here https://documentation.solarwinds.com/en/success_center/SEM/Content/Admin_Guide/2-sem_set-up_config_m... 

Please reach out to our Support, they will promptly help you, if this does not work correctly. 

0 Kudos