cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post

jobengineworker2 High CPU utilization

I have CPU utilization on my Additional Polling engines(even primary at times) with jobengineworker2 processes being the top contributor(s). In SolarWinds.APM.Probes_[PID].log, I see the below entries fill up:

2018-03-27 08:34:49,574 [317] [A(null)] [C(null)] WARN  SolarWinds.APM.Common.Diagnostics.PerformanceCounters - Initialization of performance counters SolarWinds: SAM Jobs(_Total) failed

System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.

   at System.Diagnostics.PerformanceCounter.InitializeImpl()

   at System.Diagnostics.PerformanceCounter.get_RawValue()

   at SolarWinds.APM.Common.Diagnostics.PerformanceCounters.GetPerformanceCounter(String category, String counterName, String instanceName, PerformanceCounterInstanceLifetime instanceLifetime)

   at SolarWinds.APM.Common.Diagnostics.PerformanceCounters.CreateInstancePerformanceCounters(String category, CounterCreationDataCollection counterDefs, String instanceName, PerformanceCounterInstanceLifetime lifeTime)

   at SolarWinds.APM.Common.Diagnostics.PerformanceCounters.InitializeCounters(Object state)

2018-03-26 16:31:31,040 [206] [A(null)] [C(null)] WARN  SolarWinds.APM.Common.Diagnostics.PerformanceCounters - Error creating counter

System.InvalidOperationException: The requested Performance Counter is not a custom counter, it has to be initialized as ReadOnly.

   at System.Diagnostics.PerformanceCounter.InitializeImpl()

   at System.Diagnostics.PerformanceCounter.get_RawValue()

   at SolarWinds.APM.Common.Diagnostics.PerformanceCounters.GetPerformanceCounter(String category, String counterName, String instanceName, PerformanceCounterInstanceLifetime instanceLifetime)

I have rebuilt the performance counters on affected polling engines per Performance counters are not working or missing in PerfMon - SolarWinds Worldwide, LLC. Help and Sup... , but that did not  help. I do not have many unknowns in my environment too, if that is a suspicion.

If anyone else has seen this too, please help.

0 Kudos
3 Replies

Hi Aparna, This looks like the PerfMon Counters are corrupted or missing - aLTeReGo answered this in another similar post some time back - Understanding entries in Polling Agent logs. Hope that helps.

- David Smith

I have rebuilt the performance counters using lodctr /R already, that did not help me. I have also rebuilt the .Net performance counters, no luck with that as well.

0 Kudos

Hi,

Im having this same issue. I have rebuilt these counters and it did not help. Did you ever resolve this?

0 Kudos