Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 15

WMI query fails due to bad reverse lookup

Since I couldn't find an answer in the forums and had to track down an issue I figured I would share my findings.

WMI queries to a particular server were failing and I couldn't get them to work. The only message the tests from APM provided were Unable to connect to "x.x.x.x" for WMI access.

 I opened up wmimgmt.msc on my SolarWinds server and was able to connect to the failed server in question so I coudn't figure out why it wasn't working.  I'm not sure what led me down this path but I did a reverse lookup on the IP address and found it didn't match the name of the server in question and in fact was a completely different machine to begin with.  I then tried the same test from wmimgmt.msc to the IP address and not the name and it failed.  

After some internet research I found that by default a WMI query to an IP address (the manner in which APM sends) automatically does a reverse lookup and if it gets a successful answer back sends the query to the name it received from its lookup which in my case was the wrong server.  As I understand it had the reverse lookup not returned a result the query would have gone to the original destination of the IP address.

Sure this is just another reason in a very very long list of reasons to keep your DNS entries clean and up to date but this one took me about a day and a half to figure out...Now I'm waiting on my support team to remove the invalid entry from DNS.

Like I said I scanned these forums for this particular issue and couldn't find any other threads referencing this problem so figured I would share.

Tags (2)
4 Replies

So glad to come across this post, as it's a great reminder to keep DNS clean and updated. We have a picture w/haiku hanging in our office that reminds us: 

It's not DNS
It couldn't be DNS
It was DNS

Smiley Very Happy

Someday I'm going to write a PowerShell script that will validate PTR records in reverse lookup zones and notify us of any missing ones. Someone has probably done this already, though?

0 Kudos

This is Absolute answer for the issue of WMI we normally face.

In case we cleared all troubleshooting and imagine WMI is configured properly on target host / node, but still if WBEMTEST and SolarWinds showing test failed, the final thing we need to check is the DNS entry for the target node / host. If DNS Forward and Reverse Lookup entries proper for the node then WMI test will pass successfully.

The above answer should be marked as proper. Thanks  @Mike Driskell

0 Kudos
Level 8

Thank you, thank you, thank you! I had this exact problem.

Level 15

Follow up.  As soon as the invalid entry was removed from DNS the APM components worked normally.