cancel
Showing results for 
Search instead for 
Did you mean: 
Create Post
Level 10

Undefined status for SQL Server 2005 WMI application

Jump to solution

I am attempting to assign the SQL Server 2005 WMI template to a server and some of the component monitors are returning a "failed with undefined status" result. The SQL Server Process and Browser components are passing. Also, the SQL Server Port is failing with a message of "not available" because the connection over port 1433 was refused.

Any ideas on what is causing the problem?

See screen shot.

0 Kudos
1 Solution

We battled this (on a bunch of services).

Basically, we found that if it is a WMI based poller, you need to have WMI running, RPC running, AND RPC Locator running.  Otherwise, you'll end up with unknown statuses.

View solution in original post

0 Kudos
4 Replies
Level 7

I know I am digging up the past, but did you ever get this to work?

0 Kudos

We battled this (on a bunch of services).

Basically, we found that if it is a WMI based poller, you need to have WMI running, RPC running, AND RPC Locator running.  Otherwise, you'll end up with unknown statuses.

View solution in original post

0 Kudos

Basically, we found that if it is a WMI based poller, you need to have WMI running, RPC running, AND RPC Locator running.  Otherwise, you'll end up with unknown statuses.

That didn't work for me, for SAM 6.2.2, SQL Server 2012 SP2, SQL Server 2012 Performance (WMI) template. Only four component monitors test as "up", the rest - "unknown". Three services pickerin mentioned are running, including RPC Locator. Anyone found a solution?

Screen Shot 2015-11-11 at 3.11.11 PM.png

0 Kudos
Level 15

See if the suggestions in the following post offer any possible solutions.

Negative WMI Counter Values

0 Kudos